For direct access use https://forums.oldunreal.com
It's been quite a while since oldunreal had an overhaul, but we are moving to another server which require some updates and changes. The biggest change is the migration of our old reliable YaBB forum to phpBB. This system expects you to login with your username and old password known from YaBB.
If you experience any problems there is also the usual "password forgotten" function. Don't forget to clear your browser cache!
If you have any further concerns feel free to contact me: Smirftsch@oldunreal.com

ALAudio and custom coding

Hardware & Driver related problems
Post Reply
MrBin
OldUnreal Member
Posts: 5
Joined: Sun May 16, 2021 5:09 am

ALAudio and custom coding

Post by MrBin »

Hello. I've mentioned in a previous post, that I'm working with a prototype of HP2 PC, which is based on UE1. Custom coding straight to the bone (both UnrealScript and CPP); and that is the problem.
I'm having... "sound leaks" of some sort: After playing for a good while (or rather, switching enough maps to reach 1/3 of the game), it will randomly reject playing random kinds of sounds. After two days, I haven't found any other particular pattern beyond this. As you can imagine, the game does an extensive usage of StopSound/PauseSounds/RestartSounds and similar requests (all over the place, including CPP files, native calls straight from script, and even calls through the console), including some of my own.

I wish I knew what other info could be important to analyze, nor I expect ALAudio to be foolproof with its memory management, but for now, just which particular scenario would cause a leak? Pausing sounds -> Switching Map -> Missing a restartsounds request?
Some obscure quirk I don't know about? Anything I should be particularly careful with, let alone whether has it been previously documented at all?

Any help is welcome, and I'd gladly provide any more information deemed necessary.

EDIT: I'm aware that there's a new version here, and I confess I got to test it yet, but I'm also trying my best to retain compatibility on older systems as well so everything should work in both; the same way I just installed an unofficial DirectX11 renderer AND added more chances for the game to flush its caches (which fixes transparency bugs under DirectX7 unless precache is disabled)
MrBin
OldUnreal Member
Posts: 5
Joined: Sun May 16, 2021 5:09 am

Re: ALAudio and custom coding

Post by MrBin »

Looks like I can't edit the post anymore?
Anyway, I'm "done"; just wanted to say that the problem isn't caused from the game's side, but rather this version of ALAudio happens to be particularly glitchy. Sorry for wasting your time!
Post Reply
  • Similar Topics
    Replies
    Views
    Last post

Return to “Hardware & Drivers”