logo
Main

Forums

Downloads

Unreal-Netiquette

Donate for Oldunreal:
Donate

borderline

Links to our wiki:
Wiki

Walkthrough

Links

Tutorials

Unreal Reference

Usermaps

borderline

Contact us:
Submit News
Page Index Toggle Pages: 1 Send TopicPrint
Normal Topic UnrealEd 2.0 settings not saved (Read 177 times)
Stogie83
New Member
*
Offline


Oldunreal member

Posts: 4
Joined: May 6th, 2020
UnrealEd 2.0 settings not saved
May 6th, 2020 at 10:23pm
Print Post  
Hi all,
After how many years, i installed UT99 again, because quarantine, and having to much time i wanted to try myself in mapping again.
But everytime i start UnrealED 2.0, my viewport are back to default settings, under "File" it doesn´t show the last map i´ve opened, and autosave doesn´t work.
I heard years ago that this issue happened under Win8, that settings wont be saved in the .ini file, i´m using Win10.
Is there any workaround, or what do i have to edit in the .ini file to have at least autosave working and Ed remembers my viewport settings please?
  
Back to top
 
IP Logged
 
Hellkeeper
Global Moderator
*****
Offline


Soulless Automaton

Posts: 2863
Location: France
Joined: May 21st, 2008
Gender: Male
Re: UnrealEd 2.0 settings not saved
Reply #1 - May 7th, 2020 at 12:52pm
Print Post  
I had this problem for a while too, using Windows 10. I have no idea what caused it, you can see how I and a few others tries to find the source here.
For some reason, UnrealEd seems to be unable to write anything in UnrealEd.ini, so viewport configuratiion, "Most Recently Used" textures, maps or packages are now written, the software basically resets every time you shut it down. If you write manually in UnrealEd.ini, it will work: adding a map to the list of last opened map will make it appear in UnrealEd, but it will never be replaced by new ones as you use the editor.

Unfortunately, I found no fix except reinstalling the entire game. Sad
  

You must construct additional pylons.
Back to top
WWW  
IP Logged
 
Stogie83
New Member
*
Offline


Oldunreal member

Posts: 4
Joined: May 6th, 2020
Re: UnrealEd 2.0 settings not saved
Reply #2 - May 7th, 2020 at 1:43pm
Print Post  
Tried reinstalling already, no luck. And tried several other things too from the link you posted (thanks btw). Nothing. Ended up manually editing the .ini file, but what is the command line for autosave please?

And will there be a fix in v469 update?
  
Back to top
 
IP Logged
 
Hellkeeper
Global Moderator
*****
Offline


Soulless Automaton

Posts: 2863
Location: France
Joined: May 21st, 2008
Gender: Male
Re: UnrealEd 2.0 settings not saved
Reply #3 - May 7th, 2020 at 2:16pm
Print Post  
So far I've not seen anybody able to explain why this happens and it seems to come and go at random, not easily reproducible. I guess it must be pinpointed with some accuracy to be fixed by patch 469.
Which I have tried by the way, but reinstalling the game under another folder name had fixed the bug even before, so it is not something in the patch that fixed the issue for me.

Maybe try to reinstall the game somewhere else, like in a folder named UT99 instead of the default UnrealTournament?

The command for autosave is in UnrealTournament.ini, under [Editor.EditorEngine], set AutoSave=True.
  

You must construct additional pylons.
Back to top
WWW  
IP Logged
 
[]KAOS[]Casey
Developer Team
Betatester
Offline


nedm

Posts: 3182
Joined: Aug 7th, 2011
Gender: Male
Re: UnrealEd 2.0 settings not saved
Reply #4 - May 8th, 2020 at 3:37am
Print Post  
Looks like there's some unrealed related registry keys at HKEY_CURRENT_USER\Software\Epic MegaGames\UnrealEd
  
Back to top
 
IP Logged
 
Stogie83
New Member
*
Offline


Oldunreal member

Posts: 4
Joined: May 6th, 2020
Re: UnrealEd 2.0 settings not saved
Reply #5 - May 9th, 2020 at 10:42pm
Print Post  
[]KAOS[]Casey wrote on May 8th, 2020 at 3:37am:
Looks like there's some unrealed related registry keys at HKEY_CURRENT_USER\Software\Epic MegaGames\UnrealEd


There isn´t any unrealed entry in the reg! Maybe this is the issue?
  
Back to top
 
IP Logged
 
eGo
Developer Team
Betatester
Offline


aahhh

Posts: 86
Location: Germany
Joined: Mar 8th, 2008
Gender: Male
Re: UnrealEd 2.0 settings not saved
Reply #6 - May 10th, 2020 at 2:38pm
Print Post  
Registry entries only stored by UEd V1...v2 and higher uses INI file for the settings.

If you really need v436 to work with....install it into a VM with XP or Win7  Wink
  

Tool Developer & Software Engineer
http://www.ego-creations.de
Back to top
WWW  
IP Logged
 
Stogie83
New Member
*
Offline


Oldunreal member

Posts: 4
Joined: May 6th, 2020
Re: UnrealEd 2.0 settings not saved
Reply #7 - May 10th, 2020 at 5:04pm
Print Post  
eGo wrote on May 10th, 2020 at 2:38pm:
Registry entries only stored by UEd V1...v2 and higher uses INI file for the settings.

If you really need v436 to work with....install it into a VM with XP or Win7  Wink


What are the other options? Don´t have XP or Win7 anymore.

Another weird problem that showed up today, i was moving a light actor,  the editor crashed. At first, when trying to re-open the map in Ed, it crashed again.
More, my mouse was acting weird when i tried to play UT. Had to restart the PC to fix it. Anyone had to deal with that weird issue?

EDIT: Installed Unreal 1 Gold, installed the 227i patch, works like a charm, settings getting saved, and i can continue working on my map.
« Last Edit: May 11th, 2020 at 4:01pm by Stogie83 »  
Back to top
 
IP Logged
 
Page Index Toggle Pages: 1
Send TopicPrint
Bookmarks: del.icio.us Digg Facebook Google Google+ Linked in reddit StumbleUpon Twitter Yahoo