logo
Main

Forums

Downloads

Unreal-Netiquette

Donate for Oldunreal:
Donate

borderline

Links to our wiki:
Wiki

Walkthrough

Links

Tutorials

Unreal Reference

Usermaps

borderline

Contact us:
Submit News
Page Index Toggle Pages: 1 Send TopicPrint
Normal Topic Custom Map Pack "Legacy" by EZKeel Crashes When Launched (Read 547 times)
Fred
Junior Member
**
Offline


Oldunreal member

Posts: 92
Joined: Jun 19th, 2009
Gender: Male
Custom Map Pack "Legacy" by EZKeel Crashes When Launched
Apr 27th, 2020 at 11:12pm
Print Post  
Hello,

The last time I played Legacy several years ago, it launched and worked properly.  Today I launched it from withing UT99 (selected > Game > New Single Player Game > Map Pack > Legacy).

UT99 played the first information only map (Legacy-00.unr), but when it loaded the actual game map (Legacy-1.unr) it carshed with the message to the effect that an error occurred.  No other information given.

Using Windows Explorer, I sent a shortcut to the desktop for Legacy-1.unr, and I launched it from there.

The actual map opened and I fround myself in the small locked room, from which I escaped through a vent and ductwork to the main floor below.

I don't know whether the game would work properly by starting it that way, but it launched and seemed to work.  I only tested it a little.

However, I noted that I couldn't save the game, as the option was grayed out.  So, maybe it doesn't work properly by starting it that way.

My other large map packs, including Seven Bullets, Xdia Gold and others work, so the only one that doesn't work is Legacy.

I even tried reinstalling the map pack from the Legacy UMOD file I have saved on a CD from the original download I made when I installed the maps several years ago.  That move didn't help.

I'm running Windows 10 64 bit, all up to date.  I have a powerful graphics card a powerful Intel processor.  In any case, it doesn't take much power these days to run these type maps.

Any one have some idea of what the problem could be?

Thanks,

Fred
  
Back to top
 
IP Logged
 
Fred
Junior Member
**
Offline


Oldunreal member

Posts: 92
Joined: Jun 19th, 2009
Gender: Male
Re: Custom Map Pack "Legacy" by EZKeel Crashes When Launched
Reply #1 - Apr 28th, 2020 at 12:46pm
Print Post  
The way I see this problem, is that there's something wrong with the first map's (Legacy-00.unr) ability to launch the first actual game map (Legacy-1.unr).

I say this because I can launch the Legacy-1.unr map from a desktop shortcut, and it runs (see my posting comments).

Maybe I don't understand this situation (likely), but that's my reasoning.  Does this reasoning help someone to get a handle on this problem?

That is, is it possible to fix the connection between the two maps?

It would be nice if I could get this map pack to function properly.

Fred
  
Back to top
 
IP Logged
 
Fred
Junior Member
**
Offline


Oldunreal member

Posts: 92
Joined: Jun 19th, 2009
Gender: Male
Re: Custom Map Pack "Legacy" by EZKeel Crashes When Launched
Reply #2 - Apr 28th, 2020 at 6:08pm
Print Post  
Hello,

I have new information that may be helpful.  I have another computer on which I also have installed UT99 and custom maps.

On this other computer, I launched UT99 and Legacy.  It worked perfectly, but then I could see exactly where the problem was on my computer that crashes when launching Legacy.

The game doesn't crash on the problem computer when trying to load Legacy-1.unr as it seems and as I posted previously.

The first map to run when you launch Legacy, is Legacy-00.unr.  This map displays the credits and after that it plays a cutscene.

When the cutscene completes, it loads Legacy-1.unr, the first map where one can actually start playing.  Works fine on my other computer.

So, my game crashes on the problem computer when it tries to play the cutscene, or is it that UT99 crashes when the cutscene starts.

yes, I think that's the problem, or seems to me to be the problem:  UT99 crashes when the cutscene commences.

OK, guys.  I know there's smart people here that may be able to see what's going on with this situation.

Any one?

Fred

  
Back to top
 
IP Logged
 
Fred
Junior Member
**
Offline


Oldunreal member

Posts: 92
Joined: Jun 19th, 2009
Gender: Male
Re: Custom Map Pack "Legacy" by EZKeel Crashes When Launched
Reply #3 - Apr 28th, 2020 at 10:35pm
Print Post  
More information.  It finally occurred to me to check Windows 10 Event Viewer.  Here is the pertinent information from Event Viewer:

Faulting application name Unreal Tournament.exe.  Faulting module name: WRAP.Oal.dll, veresion 1.1.2.0.  Exception code Oxc0000094.

I used Google to search on WRAP_oal.dll.  Here is what I found:

What is wrap_oal.dll?

wrap_oal.dll is part of Creative Labs OpenAL32 and developed by Creative Labs according to the wrap_oal.dll version information. wrap_oal.dll's description is "OpenAL32" wrap_oal.dll is digitally signed by Creative Labs Inc. wrap_oal.dll is usually located in the 'c:\Windows\System32\' folder.

Anyone know what to make of this?  I have no idea, but WRAP_oal.dll sounds like something that may have been installed by one of the updates, but just a guess.

For example, I installed RTNP Ultimate Edition lately.  Maybe that?

Fred 
« Last Edit: Apr 28th, 2020 at 11:46pm by Fred »  
Back to top
 
IP Logged
 
Fred
Junior Member
**
Offline


Oldunreal member

Posts: 92
Joined: Jun 19th, 2009
Gender: Male
Re: Custom Map Pack "Legacy" by EZKeel Crashes When Launched
Reply #4 - Apr 29th, 2020 at 12:33am
Print Post  
I found WRAP.oal.dll located in the following 3 places on my hard drive:

C:\Unreal\System (date modified 10/15/18) 434 KB

C:\Windows\SysWOW64 (date modified 8\12\16) 228 KB

C:\NaPali\System (date modified 10\8\15) 434 KB

Maybe this means something to someone in the know?

Fred
  
Back to top
 
IP Logged
 
Fred
Junior Member
**
Offline


Oldunreal member

Posts: 92
Joined: Jun 19th, 2009
Gender: Male
Re: Custom Map Pack "Legacy" by EZKeel Crashes When Launched
Reply #5 - Apr 29th, 2020 at 11:28am
Print Post  
All,

OK, FIXED IT!

I copied the WRAP.oal.dll from the other computer I have where UT99 and Legacy are working properly.

Since Google stated that the WRAP.oal.dll is usually found in System32, and the crashing computer didn't have it there, I copied it to there on my crashing computer.

That move didn't fix it.  Legacy still crashed when playing the cutscene.

I then copied WRAP.oal.dll to SysWOW64 on the crashing computer.  Note that the SysWOW64 version of WRAP.oal.dll on the crashing computer is only 228 KB, while all the others are 434 KB.

THAT MOVE FIXED IT!

My former crashing UT99 now plays Legacy with no issues.  Amazing!!

I had no idea how to go about fixing this.  Windows Event Viewer gave me the insight to start looking at this problem correctly.  That's all it took.  You gotta know something about what you're trying to do.  Ha!

Fred
  
Back to top
 
IP Logged
 
Fred
Junior Member
**
Offline


Oldunreal member

Posts: 92
Joined: Jun 19th, 2009
Gender: Male
Re: Custom Map Pack "Legacy" by EZKeel Crashes When Launched
Reply #6 - May 1st, 2020 at 1:03am
Print Post  
All,

Well, I introduced another problem when I copied the 435 KB version of WRAP.Oal.dll to the C:\Windows\SysWOW64 folder.

After doing that, the Legacy custom map works in UT99.  But, to do that, I had to rename the 228 KB version of WRAP.Oal.dll there to WRAP.OalOld.dll (can't install two files with the same name). 

Here is the problem I introduced:  UT99 and Unreal and RTNP Ulltimate Edition use the 228 KB version of WRAP.Oal.dll for AL Audio.

Now I have no AL Audio in those games.  FMOD Audio works, though, allowing me to retain the 435 KB version of the .dll in the SysWOW64 folder to keep the Legacy custom map working in UT99.

I copied the 435 KB version of WRAP.Oal.dll to UT99 System folder, but that didn't fix anything. 

Anyone know how I can fix this dilemma to keep AL Audio as the default audio device?

As information, here are the locations to which the WRAP.Oal.dlls were located before I installed the 435 KB version in SysWOW64 folder.

C:\Unreal\System (date modified 10/15/18) 434 KB

C:\Windows\SysWOW64 (date modified 8\12\16) 228 KB

C:\NaPali\System (date modified 10\8\15) 434 KB

If this is confusing, feel free to ask questions.

Fred
« Last Edit: May 1st, 2020 at 9:06am by Fred »  
Back to top
 
IP Logged
 
[]KAOS[]Casey
Developer Team
Betatester
Offline


nedm

Posts: 3205
Joined: Aug 7th, 2011
Gender: Male
Re: Custom Map Pack "Legacy" by EZKeel Crashes When Launched
Reply #7 - May 1st, 2020 at 1:05am
Print Post  
It might be worth trying to use OpenAL soft's binaries. https://kcat.strangesoft.net/openal.html
  
Back to top
 
IP Logged
 
Fred
Junior Member
**
Offline


Oldunreal member

Posts: 92
Joined: Jun 19th, 2009
Gender: Male
Re: Custom Map Pack "Legacy" by EZKeel Crashes When Launched
Reply #8 - May 1st, 2020 at 9:03am
Print Post  
Hi Casey,

Thanks.  I'll try most anything.  I downloaded the latest version of Open AL, but I have no idea how to install it to enable AL Audio to function in the games as indicated in my post.

Where do I install, or how do I install, whatever Open AL file I have when I unzip the download?

The Open AL zip file is sitting in my Download folder.

Fred

Edit:  I took a look inside that downloaded Open AL zip file.  There are lots of files in that downloaded zip file, maybe several dozen totaling about 10 MB.  I doubt I need all that just to replace a 228 KB WRAP.Oal.dll file.  I'm confused.

Edit 2:  My other computer (Win10 64 bit), that also has the Legacy custom map by EZkeel, only has two WRAP.Oal.dll files on the entire compter:  One in the NaPali System folder, and one in the Unreal System folder.  The Legacy map works properly there.  There is nothing in the SysWOW folder on that computer relating to this issue.

This fact leads me to believe that one of the updates on my computer, the one with issues, caused the problem.  I suspect it was the NaPali Ultimate Edition I installed recently.
« Last Edit: May 1st, 2020 at 4:33pm by Fred »  
Back to top
 
IP Logged
 
Page Index Toggle Pages: 1
Send TopicPrint
Bookmarks: del.icio.us Digg Facebook Google Google+ Linked in reddit StumbleUpon Twitter Yahoo