logo
Main

Forums

Downloads

Unreal-Netiquette

Donate for Oldunreal:
Donate

borderline

Links to our wiki:
Wiki

Walkthrough

Links

Tutorials

Unreal Reference

Usermaps

borderline

Contact us:
Submit News
Page Index Toggle Pages: 1 Send TopicPrint
Normal Topic Ryzen3/Vega3 and 227i (Read 362 times)
Buster
Global Moderator
*****
Offline



Posts: 1521
Location: BC, Canada
Joined: Jun 8th, 2005
Gender: Male
Ryzen3/Vega3 and 227i
Apr 26th, 2020 at 1:21am
Print Post  
Ryzen3/Vega3 and 227i

I have a HP 17-ca1001ca laptop with an AMD Ryzen 3 3200U CPU, 8.0 GB RAM and a Radeon Vega 3 GPU, 2.0 GB VRAM, Windows 10 version 1903, and all the latest drivers.

I have installed Unreal Gold from an original CD, without the Editor and DIVX selected. I did not select Old Weapons with the 227i install.

If I first run with the GL graphics and the AL audio the game runs poorly. There is a lot of VSync problems with the graphics, and a really noticeable tingy effect with the audio.

I have tried various solutions and all have had little effect.

I have found it BEST to first run Unreal with the D3D9RenderDevice and the GalaxyAudioSubsystem. The game runs perfectly.

It is a quirk with the Ryzen3/Vega3 hardware. I hope this info helps those with a similar problem with AMD stuff.
  

Gatherstone - Unreal by Design
https://gatherstone.oldunreal.com

OK - he falls
Keep it Unreal !!
Smiley_~
Back to top
WWW  
IP Logged
 
lowenz
Senior Member
Betatester
****
Offline


Unreal Veteran

Posts: 297
Location: Berghem Haven
Joined: Dec 28th, 2007
Gender: Male
Re: Ryzen3/Vega3 and 227i
Reply #1 - Apr 26th, 2020 at 7:01am
Print Post  
GL or XGL?

The OpenAL problem is strange, more like a Windows issue OR an audio device driver problem.
Try to use this(32 bit one): https://openal-soft.org/openal-binaries/openal-soft-1.20.1-bin.zip

227i has an old version of OpenAL Soft, not really compatible with Windows 1903/1909 build

Rename soft_oal.dll -> openal32.dll and put it in the System dir (backup the old one).

Galaxy driver is solid but you can't have the positional 5.1 (well 4, OpenAL Soft really doesn't use LFE and center channels) audio.
  

The task is not so much to see what no one has yet seen, but to think what nobody has yet thought, about that which everybody sees - E.S.
Back to top
 
IP Logged
 
lowenz
Senior Member
Betatester
****
Offline


Unreal Veteran

Posts: 297
Location: Berghem Haven
Joined: Dec 28th, 2007
Gender: Male
Re: Ryzen3/Vega3 and 227i
Reply #2 - May 16th, 2020 at 6:55am
Print Post  
Any news?
  

The task is not so much to see what no one has yet seen, but to think what nobody has yet thought, about that which everybody sees - E.S.
Back to top
 
IP Logged
 
Page Index Toggle Pages: 1
Send TopicPrint
Bookmarks: del.icio.us Digg Facebook Google Google+ Linked in reddit StumbleUpon Twitter Yahoo