logo
Main

Forums

Downloads

Unreal-Netiquette

Donate for Oldunreal:
Donate

borderline

Links to our wiki:
Wiki

Walkthrough

Links

Tutorials

Unreal Reference

Usermaps

borderline

Contact us:
Submit News
Page Index Toggle Pages: 1 Send TopicPrint
Hot Topic (More than 10 Replies) UT99: GameRenderDevice option has disappeared (Read 262 times)
javic
New Member
*
Offline


Oldunreal member

Posts: 6
Joined: Oct 19th, 2019
UT99: GameRenderDevice option has disappeared
Oct 19th, 2019 at 3:28am
Print Post  
I recently reinstalled UT99 on 64-bit Win7. I had it installed previously and it was working fine but I wanted to clean out some old mods/maps I no longer use and so decided to start fresh. I backed up my old installation, uninstalled, and then installed from original retail CD, then added the V436 patch and updated OpenGL & Direct3D drivers.

In my previous installation, under Advanced Options > Drivers, I had the "GameRenderDevice" option that allowed me to select a renderer. Both Direct3D and OpenGL worked fine.

But with the new installation, the "GameRenderDevice" option no longer appears; I have only the other four settings under "Drivers". What's more, with my backed up old installation, the "GameRenderDevice" option--which was previously present--has disappeared. And if I choose Direct3D via regular Options (not Advanced Options) the game now crashes.

So it seems that reinstalling UT99 screwed up something on my system, but I have no idea what. Uninstalling the new install does not restore the "GameRenderDevice" option or Direct3D functionality of the old installation, so there's apparently no simple "undo".

Anybody have any idea what's going on? (I do have a recent restore point I can return to if necessary, but would prefer to figure this out and fix it.) Thanks in advance for any help.

Update: Just for yucks, I did go back to a recent restore point. It had no effect. The "GameRenderDevice" option is still absent, and choosing the Direct3D renderer still crashes the game.
  
Back to top
 
IP Logged
 
medor
Senior Member
Betatester
****
Offline


Oldunreal member

Posts: 303
Joined: May 17th, 2009
Re: UT99: GameRenderDevice option has disappeared
Reply #1 - Oct 20th, 2019 at 4:01pm
Print Post  
Open your UnrealTournament.ini and add edit



[OpenGLDrv.OpenGLRenderDevice]
FrameRateLimit=150
Translucency=True
VolumetricLighting=False
ShinySurfaces=False
Coronas=False
HighDetailActors=True
DetailTextures=False
UseBGRATextures=True
OneXBlending=True
TruFormMinVertices=0
TruFormTessellation=3
UseTruForm=False
RequestHighResolutionZ=True
UseMultiDrawArrays=False
BufferClippedActorTris=False
SinglePassDetail=False
DetailClipping=False
RefreshRate=85
UseTNT=False
UseS3TC=False
UseAlphaPalette=False
AutoGenerateMipmaps=False
UsePrecache=False
ShareLists=False
UsePalette=True
UseZTrick=False
MaxLogTextureSize=8
MinLogTextureSize=0
MaxLogVOverU=8
MaxLogUOverV=8
GammaCorrectScreenshots=True
GammaOffset=0.150000
DescFlags=0
Descrïption=
GammaOffsetBlue=0.000000
GammaOffsetGreen=0.000000
GammaOffsetRed=0.000000
FastTranslucency=1
VertexLighting=0
Translucency=1
UseVertexSpecular=1
UseTrilinear=False
UseS3TC=True
LODBias=0.000000
MaxAnisotropy=0
SupportsLazyTextures=1
GammaOffset=0.150000
NumAASamples=0
UseAA=False
SwapInterval=0
UseVertexProgram=False
UseCVA=False
UseMultiDrawArrays=True
UseSSE=2
AAFilterHint=0
TexDXT1ToDXT3=False
DynamicTexIdRecycleLevel=100
UseTexPool=True
UseTexIdPool=True
BufferClippedActorTris=True
SinglePassDetail=True
ColorizeDetailTextures=False
DetailClipping=True
UseDetailAlpha=True
NoFiltering=False
UseFilterSGIS=False
Use4444Textures=False
UseAlphaPalette=True
UsePrecache=True
AlwaysMipmap=True
ShareLists=True
UseMultiTexture=True
MaskedTextureHack=False
MaxTMUnits=0
Translucency=1
UseVertexSpecular=1
UseTrilinear=False
UseS3TC=True
LODBias=0.000000
MaxAnisotropy=0
SupportsLazyTextures=1
GammaOffset=0.420000
NumAASamples=0
UseAA=False
SwapInterval=0
UseVertexProgram=False
UseCVA=False
UseMultiDrawArrays=True
UseSSE=2
AAFilterHint=0
TexDXT1ToDXT3=False
DynamicTexIdRecycleLevel=100
UseTexPool=True
UseTexIdPool=True
BufferClippedActorTris=True
SinglePassDetail=True
ColorizeDetailTextures=False
DetailClipping=True
UseDetailAlpha=True
NoFiltering=False
UseFilterSGIS=False
Use4444Textures=False
UseAlphaPalette=True
UsePrecache=True
AlwaysMipmap=True
ShareLists=True
UseMultiTexture=True
MaskedTextureHack=False
MaxTMUnits=0

[D3D9Drv.D3D9RenderDevice]
UseVSync=False
SwapInterval=0
ZRangeHack=False
NoAATiles=False
NumAASamples=0
UseAA=False
RequestHighResolutionZ=True
UseSoftwareVertexProcessing=False
UsePureDevice=True
UseTripleBuffering=False
MaskedTextureHack=False
SmoothMaskedTextures=False
FrameRateLimit=150
UseVertexProgram=True
TexDXT1ToDXT3=False
DynamicTexIdRecycleLevel=100
CacheStaticMaps=False
UseTexPool=True
UseTexIdPool=True
UseSSE2=True
UseSSE=True
BufferTileQuads=True
BufferClippedActorTris=True
SinglePassDetail=False
SinglePassFog=False
ColorizeDetailTextures=False
DetailClipping=False
UseDetailAlpha=True
DetailMax=0
RefreshRate=0
MaxTMUnits=0
NoFiltering=False
MaxAnisotropy=0
Use565Textures=False
Use16BitTextures=False
UseS3TC=False
UseAlphaPalette=False
UseTrilinear=False
UsePrecache=False
UsePalette=False
UseMultiTexture=True
MaxLogTextureSize=8
MinLogTextureSize=0
MaxLogVOverU=8
MaxLogUOverV=8
OneXBlending=True
GammaCorrectScreenshots=False
GammaOffsetBlue=0.000000
GammaOffsetGreen=0.000000
GammaOffsetRed=0.000000
GammaOffset=0.100000
LODBias=0.000000
DetailTextures=False
DescFlags=0
Description=
HighDetailActors=False
Coronas=False
ShinySurfaces=False
VolumetricLighting=False

set your full screen corretly




  
Back to top
 
IP Logged
 
javic
New Member
*
Offline


Oldunreal member

Posts: 6
Joined: Oct 19th, 2019
Re: UT99: GameRenderDevice option has disappeared
Reply #2 - Oct 20th, 2019 at 8:30pm
Print Post  
Sorry, didn't have any effect (I already had OpenGL & Direct3D sections in the INI, but I replaced them with these settings anyway).
  
Back to top
 
IP Logged
 
Dr.Flay™
Senior Member
****
Offline


ChaosUT-333networks

Posts: 378
Location: Kernow, UK
Joined: Dec 9th, 2012
Gender: Male
Re: UT99: GameRenderDevice option has disappeared
Reply #3 - Oct 21st, 2019 at 4:03am
Print Post  
Changing your renderer settings won't help (as you discovered).

For the renderers to list in the advanced options you need to have the matching int files.
eg. the DX9 renderer is mounted in the list with these lines in the file
D3D9Drv.int
Code
Select All
[Public]
Object=(Name=D3D9Drv.D3D9RenderDevice,Class=Class,MetaClass=Engine.RenderDevice,Autodetect=d3d9.dll)
Preferences=(Caption="Rendering",Parent="Advanced Options")
Preferences=(Caption="Direct3D9 support",Parent="Rendering",Class=D3D9Drv.D3D9RenderDevice,Immediate=True) 



Do you have the int files for the renderers ?
  
Back to top
IP Logged
 
javic
New Member
*
Offline


Oldunreal member

Posts: 6
Joined: Oct 19th, 2019
Re: UT99: GameRenderDevice option has disappeared
Reply #4 - Oct 23rd, 2019 at 7:48pm
Print Post  
Yes, I have three INT files for the three drivers I have installed: D3D9Drv.int, D3DDrv.int, and OpenGlDrv.int. And all three have the "Preferences" settings similar to the one you posted.
  
Back to top
 
IP Logged
 
Dr.Flay™
Senior Member
****
Offline


ChaosUT-333networks

Posts: 378
Location: Kernow, UK
Joined: Dec 9th, 2012
Gender: Male
Re: UT99: GameRenderDevice option has disappeared
Reply #5 - Oct 24th, 2019 at 3:54am
Print Post  
If you click on the in-game option to change renderers, do they list in the box that shows when it relaunches ?
  
Back to top
IP Logged
 
javic
New Member
*
Offline


Oldunreal member

Posts: 6
Joined: Oct 19th, 2019
Re: UT99: GameRenderDevice option has disappeared
Reply #6 - Oct 26th, 2019 at 9:13pm
Print Post  
Dr.Flay™ wrote on Oct 24th, 2019 at 3:54am:
If you click on the in-game option to change renderers, do they list in the box that shows when it relaunches ?


You mean via Options > Preferences > Video Driver > Change which brings up the launcher? Yes, all three (and a few others) appear in that list (when I choose "Show all devices").

(I can always change the renderer by  this route, but I'd still like to know why the option doesn't appear in Advanced Options like it did previously. It's really buggin' me. Smiley)


  
Back to top
 
IP Logged
 
medor
Senior Member
Betatester
****
Offline


Oldunreal member

Posts: 303
Joined: May 17th, 2009
Re: UT99: GameRenderDevice option has disappeared
Reply #7 - Oct 27th, 2019 at 8:02am
Print Post  
like i say up you need to add section in your UT.ini

If you install D3D11Drv like you say up
you need to open your UT.ini and add-create the section [D3D11Drv.D3D11RenderDevice]
  
Back to top
 
IP Logged
 
javic
New Member
*
Offline


Oldunreal member

Posts: 6
Joined: Oct 19th, 2019
Re: UT99: GameRenderDevice option has disappeared
Reply #8 - Oct 27th, 2019 at 10:34pm
Print Post  
Thanks, but as I said, I do have all the relevant sections in UnrealTournament.ini. Just triple-checked and they're all there. But the render device option is still absent.
  
Back to top
 
IP Logged
 
medor
Senior Member
Betatester
****
Offline


Oldunreal member

Posts: 303
Joined: May 17th, 2009
Re: UT99: GameRenderDevice option has disappeared
Reply #9 - Oct 29th, 2019 at 7:46am
Print Post  
Ah ok   sorry
  
Back to top
 
IP Logged
 
´esnesi
New Member
Betatester
*
Offline


on it!

Posts: 26
Joined: Sep 6th, 2019
Re: UT99: GameRenderDevice option has disappeared
Reply #10 - Oct 30th, 2019 at 1:18pm
Print Post  

I also hope you got the DLL files next to the INT files.

They are for sure in this one:
https://www.oldunreal.com/patch/OMP-UT-V0.2.exe

check here for older ones and separate packages:
https://www.cwdohnal.com/utglr/

The 469 patch will make the renderers valid/certified so they will show up as default renderers is what is read.
« Last Edit: Oct 30th, 2019 at 5:24pm by ´esnesi »  
Back to top
YouTube  
IP Logged
 
javic
New Member
*
Offline


Oldunreal member

Posts: 6
Joined: Oct 19th, 2019
Re: UT99: GameRenderDevice option has disappeared
Reply #11 - Oct 30th, 2019 at 5:27pm
Print Post  
Thanks, but I already installed the "utglr" drivers and the "OMP-UT-..." patch. The relevant DLLs and INTs are all present. And the drivers all appear in the launcher's list of rendering devices. It's only in the Advanced Options dialog that the display driver option has vanished.

I do appreciate all the suggestions; they're things I might have overlooked and so it was worth double-checking.

But keep in mind that I had a fully functional installation with the display driver option available in Advanced Options. Then I decided to reinstall (can't remember why now Smiley) and the option vanished. Here's what I did step-by-step:

1. Copy the current installation (with display driver option appearing in Advanced Options dialog) elsewhere for safe keeping.
2. Uninstall. Delete leftovers in game folder so folder is totally empty.
3. Reinstall UT99 (GOTY ed. BTW) from CD. Install 4.3.6 patch, Bonus Pack 4, "EAXUTSYS.EXE" (EAX library patcher - I have SB Audigy ZS), "OMP-UT-V02.exe" (multimedia update), "utglr" OpenGL & D3D9 drivers, S3TC textures, and Old Skool Amp'd mod. (Same steps I applied when installing the previous version that worked.)
4. Launch the game. Display driver setting in Advanced Options is *not present*.
5. Delete contents of game folder. Copy previous installation from backup into game folder. Assumed this would restore to previous working state. But display driver setting in Advanced Options is *still missing*. WTF?  Cry

Seems like the reinstall must have changed something outside the game folder. Found nothing obvious in the Registry. Maybe some system file has been replaced?
  
Back to top
 
IP Logged
 
´esnesi
New Member
Betatester
*
Offline


on it!

Posts: 26
Joined: Sep 6th, 2019
Re: UT99: GameRenderDevice option has disappeared
Reply #12 - Nov 1st, 2019 at 10:25am
Print Post  
I never came across this issue, nor saw any other topics about it.
And i would say a clean UT.ini or install would definitely solve this.
  
Back to top
YouTube  
IP Logged
 
Page Index Toggle Pages: 1
Send TopicPrint
Bookmarks: del.icio.us Digg Facebook Google Google+ Linked in reddit StumbleUpon Twitter Yahoo