logo
Main

Forums

Downloads

Unreal-Netiquette

Donate for Oldunreal:
Donate

borderline

Links to our wiki:
Wiki

Walkthrough

Links

Tutorials

Unreal Reference

Usermaps

borderline

Contact us:
Submit News
Page Index Toggle Pages: 1 Send TopicPrint
Hot Topic (More than 10 Replies) Needed: working opengldrv.dll for ut 4.05 (Read 342 times)
ut405player
New Member
*
Offline


Oldunreal member

Posts: 5
Joined: May 1st, 2019
Needed: working opengldrv.dll for ut 4.05
May 1st, 2019 at 3:36pm
Print Post  
Hi!
I sometimes still play infiltration UT, however I prefer the old version of Infiltration mod which works only on UT v4.05.
I would like to know if there is any good working OpenGLdrv.dll for 4.05 that I could use; D3D has start-up delay on GTX770...
Thanks.
  
Back to top
 
IP Logged
 
[]KAOS[]Casey
Developer Team
Betatester
Offline


nedm

Posts: 3168
Joined: Aug 7th, 2011
Gender: Male
Re: Needed: working opengldrv.dll for ut 4.05
Reply #1 - May 2nd, 2019 at 4:00am
Print Post  
it may be easier to just upgrade that old infil to work on new UT. It may also be possible to just copy paste a custom OGL drive for 432 on 405 and it might just work -- but dunno.

I could give converting it a shot if you upload it for me
  
Back to top
 
IP Logged
 
ut405player
New Member
*
Offline


Oldunreal member

Posts: 5
Joined: May 1st, 2019
Re: Needed: working opengldrv.dll for ut 4.05
Reply #2 - May 3rd, 2019 at 9:59am
Print Post  
Thank you for your reply - here I have a unreal-return to napali opengldrv, from this site, that works very well and another opengldrv for UT from 2001, I don't know what version that doesn't work on 4.05. I can't seem to find the "attach" button in the post form. Smiley

Edit: I tried 4.32 opengldrv.dll too and it doesn't work, UT just switches to software renderer...
  
Back to top
 
IP Logged
 
TONI-M
New Member
*
Offline


Oldunreal member

Posts: 20
Joined: Mar 14th, 2019
Re: Needed: working opengldrv.dll for ut 4.05
Reply #3 - May 3rd, 2019 at 4:19pm
Print Post  
A good OpenGLdrv.dll is the one you can download from the oldunreal site- OMP-UT-V0.2.exe - works fine, but with some video cards I disabled vertical sync and adjusted the value in the ini file. Now it works well. Family Video Radeon - Ati - 9900 - 8800.

You can keep the Sync and change only the fps value in the ini file.

Toni M.
  
Back to top
 
IP Logged
 
Dr.Flay™
Senior Member
****
Online


ChaosUT-333networks

Posts: 360
Location: Kernow, UK
Joined: Dec 9th, 2012
Gender: Male
Re: Needed: working opengldrv.dll for ut 4.05
Reply #4 - May 4th, 2019 at 3:46am
Print Post  
Have you tried the D3D9 renderer ?
« Last Edit: May 12th, 2019 at 10:45pm by Dr.Flay™ »  
Back to top
IP Logged
 
TONI-M
New Member
*
Offline


Oldunreal member

Posts: 20
Joined: Mar 14th, 2019
Re: Needed: working opengldrv.dll for ut 4.05
Reply #5 - May 4th, 2019 at 4:20pm
Print Post  
Dr.Flay ™, I did not understand if you turn to me or to someone else, I do, the same is. However with the trick of synchronism and the modification of the fps values you can adjust.

TONI-M
  
Back to top
 
IP Logged
 
ut405player
New Member
*
Offline


Oldunreal member

Posts: 5
Joined: May 1st, 2019
Re: Needed: working opengldrv.dll for ut 4.05
Reply #6 - May 5th, 2019 at 5:44pm
Print Post  
Thank you for all replies - I tried OMP-UT and OMP-UT-v.0.2 OpenGLdrv.dll and none works in UT4.05...  Sad
  
Back to top
 
IP Logged
 
medor
Senior Member
****
Offline


Oldunreal member

Posts: 277
Joined: May 17th, 2009
Re: Needed: working opengldrv.dll for ut 4.05
Reply #7 - May 6th, 2019 at 6:38am
Print Post  
ut405player wrote on May 1st, 2019 at 3:36pm:
Hi!
I sometimes still play infiltration UT, however I prefer the old version of Infiltration mod which works only on UT v4.05.
I would like to know if there is any good working OpenGLdrv.dll for 4.05 that I could use; D3D has start-up delay on GTX770...
Thanks.


just edit your unrealtournament.ini part d3d with that
or take my UT ready optimized http://unrealtournament.99.free.fr/forum/viewtopic.php?f=4&t=7

UseVSync=False
SwapInterval=0
ZRangeHack=False
NoAATiles=False
NumAASamples=0
UseAA=False
RequestHighResolutionZ=True
UseSoftwareVertexProcessing=False
UsePureDevice=True
UseTripleBuffering=False
MaskedTextureHack=False
SmoothMaskedTextures=False
FrameRateLimit=150
UseVertexProgram=True
TexDXT1ToDXT3=False
DynamicTexIdRecycleLevel=100
CacheStaticMaps=False
UseTexPool=True
UseTexIdPool=True
UseSSE2=True
UseSSE=True
BufferTileQuads=True
BufferClippedActorTris=True
SinglePassDetail=False
SinglePassFog=False
ColorizeDetailTextures=False
DetailClipping=False
UseDetailAlpha=True
DetailMax=0
RefreshRate=0
MaxTMUnits=0
NoFiltering=False
MaxAnisotropy=0
Use565Textures=False
Use16BitTextures=False
UseS3TC=False
UseAlphaPalette=False
UseTrilinear=False
UsePrecache=False
UsePalette=False
UseMultiTexture=True
MaxLogTextureSize=8
MinLogTextureSize=0
MaxLogVOverU=8
MaxLogUOverV=8
OneXBlending=True
GammaCorrectScreenshots=False
GammaOffsetBlue=0.000000
GammaOffsetGreen=0.000000
GammaOffsetRed=0.000000
GammaOffset=0.100000
LODBias=0.000000
DetailTextures=False
DescFlags=0
Description=
HighDetailActors=False
Coronas=False
ShinySurfaces=False
VolumetricLighting=False
  
Back to top
 
IP Logged
 
TONI-M
New Member
*
Offline


Oldunreal member

Posts: 20
Joined: Mar 14th, 2019
Re: Needed: working opengldrv.dll for ut 4.05
Reply #8 - May 6th, 2019 at 4:48pm
Print Post  
Dear ut405player, maybe I misunderstood, I meant to update UT. Hi TONY-M.
  
Back to top
 
IP Logged
 
Smirftsch
Forum Administrator
*****
Offline



Posts: 7901
Location: at home
Joined: Apr 30th, 1998
Gender: Male
Re: Needed: working opengldrv.dll for ut 4.05
Reply #9 - May 12th, 2019 at 8:27am
Print Post  
I think I can make an updated OpenGLDrv for 4.05, but drop me a PM in a week, before I definitely can't work on that.
  

Sometimes you have to lose a fight to win the war.
Back to top
WWWICQ  
IP Logged
 
ut405player
New Member
*
Offline


Oldunreal member

Posts: 5
Joined: May 1st, 2019
Re: Needed: working opengldrv.dll for ut 4.05
Reply #10 - May 12th, 2019 at 8:31pm
Print Post  
medor - thanks for reply but you're using D3D8 or 9 d3ddrv on UT436.
That is no problem for me...it's 4.05 I'm curious about.

Smirftsch - thank you so much for your interest. I shall PM you in a week.
Now this is a really good forum for The Classics as I call them.  Smiley
  
Back to top
 
IP Logged
 
medor
Senior Member
****
Offline


Oldunreal member

Posts: 277
Joined: May 17th, 2009
Re: Needed: working opengldrv.dll for ut 4.05
Reply #11 - May 12th, 2019 at 9:07pm
Print Post  
ut405player wrote on May 12th, 2019 at 8:31pm:
medor - thanks for reply but you're using D3D8 or 9 d3ddrv on UT436.
That is no problem for me...it's 4.05 I'm curious about.


This setting go for your bug .
Just try it.

You know how to set it ?


  
Back to top
 
IP Logged
 
Dr.Flay™
Senior Member
****
Online


ChaosUT-333networks

Posts: 360
Location: Kernow, UK
Joined: Dec 9th, 2012
Gender: Male
Re: Needed: working opengldrv.dll for ut 4.05
Reply #12 - May 12th, 2019 at 10:56pm
Print Post  
It may help if you share your renderer config and tell us the version of Infiltration, so we aren't just making wild stabs in the dark.
Kinda low on useful info here.

The default configs for D3D and GL are different. Are you sure it isn't just that or a setting that need to be changed.
eg. UsePrecache=False
If set to true you will have a delay at the beginning of the match.

Note: all video and audio renderer defaults are set for compatibility with old PCs and should be tweaked for your setup or preference.
  
Back to top
IP Logged
 
ut405player
New Member
*
Offline


Oldunreal member

Posts: 5
Joined: May 1st, 2019
Re: Needed: working opengldrv.dll for ut 4.05
Reply #13 - yesterday at 5:59pm
Print Post  
Just a reply to concerns about my UT v.4.05 D3D settings.
I am using somewhat updated D3D 7 drv from days of Radeon 8500.
I don't know where I got it but I have v5, v6, v7 and v8 of d3ddrv.dll.

On Radeons in general all versions work, but since GeForceFX v8 was the most useful. On GTX 770 v6 or v8 work, v8 better and here are my D3DDrv_settings from UnrealTournament.ini:
HighDetailActors=True
Coronas=True
ShinySurfaces=True
VolumetricLighting=True
dwDeviceId=4484
dwVendorId=4318
UsePrecache=False
UseVSync=False
UseTripleBuffering=False
Use3dfx=False
UseGammaCorrection=True
UsePalettes=False
UseMultitexture=True
UseTrilinear=True
UseMipmapping=True
DetailTextures=True
DescFlags=1
Description=NVIDIA GeForce GTX 770
UseLocalTextures=True
UseVideoMemoryVB=False
I'm not a novice at this - been at it since Voodoo1, so as you see the settings are pretty much optimal unless I missed something.
I hated precaching since it was introduced with UT and it was always OFF on Voodoo's and I always switched it off on D3D cards as well.
Thanks for your interest.
  
Back to top
 
IP Logged
 
Dr.Flay™
Senior Member
****
Online


ChaosUT-333networks

Posts: 360
Location: Kernow, UK
Joined: Dec 9th, 2012
Gender: Male
Re: Needed: working opengldrv.dll for ut 4.05
Reply #14 - Today at 1:13am
Print Post  
All versions of D3DDrv are for DirectX 5-7
Have you tried any of the DirectX9 renderers "D3D9Drv.dll" ?

What version of Infiltration is this old version ?
There are several versions of the old mutator before it became a full mod.
  
Back to top
IP Logged
 
Page Index Toggle Pages: 1
Send TopicPrint
Bookmarks: del.icio.us Digg Facebook Google Google+ Linked in reddit StumbleUpon Twitter Yahoo