logo
Main

Forums

Downloads

Unreal-Netiquette

Donate for Oldunreal:
Donate

borderline

Links to our wiki:
Wiki

Walkthrough

Links

Tutorials

Unreal Reference

Usermaps

borderline

Contact us:
Submit News
Page Index Toggle Pages: 1 ... 9 10 [11] 12 13  Send TopicPrint
Very Hot Topic (More than 25 Replies) Enhanced Monster Skins (Read 35625 times)
Lightning_Hunter
Senior Member
****
Offline



Posts: 267
Location: somewhere on Earth
Joined: Mar 4th, 2003
Gender: Male
Re: Enhanced Monster Skins
Reply #150 - Apr 20th, 2016 at 9:09pm
Print Post  
Yes, it appears to crash on any map.  I'm using UT99 version 436 with the UTGLR drivers version 3.6 found here:
http://www.cwdohnal.com/utglr/utglr36.zip

I've tried loading the mutator in the map you uploaded, as well as using Oldskool to start the original Unreal episode.  All of it crashes.  Is there maybe an invalid reference to a skin for UT99?
  

For High-Res Unreal skins, click here.
Back to top
IP Logged
 
sn260591
Full Member
***
Offline



Posts: 111
Location: Russia
Joined: Aug 17th, 2011
Gender: Male
Re: Enhanced Monster Skins
Reply #151 - Apr 21st, 2016 at 9:31am
Print Post  
I tested this renderer, but I did not have the game crash.
You are using other mutators? If so, try without them.
You can also put a log file.
  

Sorry for my bad English
Back to top
 
IP Logged
 
Lightning_Hunter
Senior Member
****
Offline



Posts: 267
Location: somewhere on Earth
Joined: Mar 4th, 2003
Gender: Male
Re: Enhanced Monster Skins
Reply #152 - Apr 21st, 2016 at 10:55pm
Print Post  
I'm not using any other mutators.  I am simply launching a map with the gametype "oldskool.SinglePlayer2" with the HDskins mutator enabled.  It also happens launching the mutator from a deathmatch game with your map.  I even tried reverting everything back to the default settings, and the crash still happens.  Here is the log:

Code
Select All
Log: Log file open, 04/21/16 16:54:22
Init: Name subsystem initialized
Init: Detected: Microsoft Windows NT 6.1 (Build: 7601)
Init: Version: 436
Init: Compiled: Oct 24 2000 23:40:18
Init: Command line:
Init: Base directory: C:\UnrealTournament\System\
Init: Character set: Unicode
Log: Bound to Engine.dll
Log: Bound to Core.dll
Log: Bound to Window.dll
Init: Object subsystem initialized
Init: Computer: EVANDELL
Init: User: EvanRose
Init: Memory total: Phys=4194303K Pagef=4194303K Virt=2097024K
Init: Working set: 32000 / 159000
Init: CPU Speed=3203.235765 MHz
Init: CPU Page size=4096, Processors=4
Init: CPU Detected: PentiumPro-class processor (GenuineIntel)
Init: CPU Features: CMov FPU RDTSC PAE MMX KNI
Localization: No localization: Startup.IDDIALOG_WizardDialog.IDC_WizardDialog (int)
Init: Unreal engine initialized
Log: Bound to WinDrv.dll
Init: Mouse info: 0 0 0
Init: Initializing DirectDraw
Log: DirectDraw drivers:
Log:    display (Primary Display Driver)
Init: DirectDraw initialized successfully
Init: Client initialized
Log: Bound to Render.dll
Init: Lighting subsystem initialized
Init: Rendering initialized
Log: LoadMap: Entry
Log: Bound to Fire.dll
Log: Bound to IpDrv.dll
Log: Game class is 'UTIntro'
Log: Level is Level Entry.MyLevel
Log: Bringing Level Entry.MyLevel up for play (0)...
ScriptLog: InitGame:
ScriptLog: Base Mutator is Entry.Mutator0
Log: Browse: CityIntro.unr?Name=Player?Class=Botpack.TMale2?team=255?skin=SoldierSkins.blkt?Face=SoldierSkins.Othello
Log: LoadMap: CityIntro.unr?Name=Player?Class=Botpack.TMale2?team=255?skin=SoldierSkins.blkt?Face=SoldierSkins.Othello
Log: Collecting garbage
Log: Purging garbage
Log: -0.0ms Unloading: Package Render
Log: Garbage: objects: 16410->16407; refs: 224628
Log: Game class is 'UTIntro'
Log: Level is Level CityIntro.MyLevel
Log: Bringing Level CityIntro.MyLevel up for play (0)...
ScriptLog: InitGame: ?Name=Player?Class=Botpack.TMale2?team=255?skin=SoldierSkins.blkt?Face=SoldierSkins.Othello
ScriptLog: Base Mutator is CityIntro.Mutator1
Init: Initialized moving brush tracker for Level CityIntro.MyLevel
Log: Bound to UWeb.dll
ScriptLog: Team 255
ScriptLog: Login: Player
Log: Possessed PlayerPawn: TMale2 CityIntro.TMale0
Init: Input system initialized for WindowsViewport0
Log: Opened viewport
Log: Bound to OpenGLDrv.dll
Log: Initializing OpenGLDrv...
Log: Enter SetRes()
Init: Using pixel format 7
Init: GL_VENDOR     : NVIDIA Corporation
Init: GL_RENDERER   : GeForce GTX 550 Ti/PCIe/SSE2
Init: GL_VERSION    : 4.5.0 NVIDIA 361.43
Init: Device supports: GL_EXT_bgra
Init: Device supports: GL_ARB_texture_compression
Init: Device supports: GL_EXT_texture_compression_s3tc
Init: Device supports: GL_EXT_texture_env_combine
Init: Device supports: GL_ARB_texture_env_combine
Init: Device supports: GL_EXT_texture_filter_anisotropic
Init: Device supports: GL_NV_texture_env_combine4
Init: Device supports: GL_EXT_texture_lod_bias
Init: Device supports: GL_EXT_secondary_color
Init: Device supports: GL_ARB_multitexture
Init: Device supports: GL_EXT_multi_draw_arrays
Init: Device supports: GL_ARB_vertex_program
Init: Device supports: GL_ARB_fragment_program
Init: Depth bits: 24
Log: 4 Texture Mapping Units found
Log: Trying to use S3TC extension.
Log: MinLogTextureSize: 2
Log: MaxLogTextureSize: 14
Log: BufferActorTris: 1
Log: UseDetailAlpha: 1
Log: Bound to Galaxy.dll
Init: Galaxy is using DirectSound
Init: Galaxy initialized
DevAudio: Galaxy SetViewport: WindowsViewport0
Init: Game engine initialized
Log: Startup time: 1.801277 seconds
DevMusic: Load music: Music Uttitle.Uttitle
ScriptLog: Creating root window: UMenu.UMenuRootWindow
Log: Bound to udemo.dll
udemo: Startup hack successful!
Log: Opening demo driver to read demo file 'c:\UnrealTournament\System\ownage5.dem'
Log: UDEMO: Successfully got list of demos
Log: FactoryCreateText: TextBuffer with TextBufferFactory (0 1 hdskins)
Log: Execing hdskins
Log: Browse: monstertest?Name=Player?Class=Botpack.TMale2?team=255?skin=SoldierSkins.blkt?Face=SoldierSkins.Othello?game=oldskool.SinglePlayer2?Mutator=HDSkins.HDSkins_mutator
Log: LoadMap: monstertest?Name=Player?Class=Botpack.TMale2?team=255?skin=SoldierSkins.blkt?Face=SoldierSkins.Othello?game=oldskool.SinglePlayer2?Mutator=HDSkins.HDSkins_mutator
DevAudio: Galaxy SetViewport: WindowsViewport0
Log: UDEMO: Successfully got list of demos
Log: Opening demo driver to read demo file 'c:\UnrealTournament\System\ownage5.dem'
Log: Closing down demo driver.
NetComeGo: Close DemoRecConnection0 04/21/16 16:54:28
Log: Closing down demo driver.
Init: Shut down moving brush tracker for Level CityIntro.MyLevel
Log: Collecting garbage
Log: Purging garbage
Log: -0.0ms Unloading: Package CityIntro
Log: -0.0ms Unloading: Package city
Log: -0.0ms Unloading: Package ArenaTex
Log: -0.0ms Unloading: Package GenFX
Log: -0.0ms Unloading: Package RainFX
Log: -0.0ms Unloading: Package DecayedS
Log: -0.0ms Unloading: Package GenIn
Log: -0.0ms Unloading: Package NaliFX
Log: -0.0ms Unloading: Package ShaneSky
Log: -0.0ms Unloading: Package AmbModern
Log: -0.0ms Unloading: Package AmbAncient
Log: -0.0ms Unloading: Package openingwave
Log: -0.0ms Unloading: Package Uttitle
Log: -0.0ms Unloading: Package AmbOutside
DevMusic: Unregister music: Music Uttitle.Uttitle
Log: -0.0ms Unloading: Package SoldierSkins
Log: -0.0ms Unloading: Package AdjustoBots
Log: -0.0ms Unloading: Package AdvSetGUI
Log: -0.0ms Unloading: Package Captain
Log: -0.0ms Unloading: Package SlaveMaster
Log: -0.0ms Unloading: Package marginal
Log: -0.0ms Unloading: Package MoreBloodOS
Log: -0.0ms Unloading: Package NWCoreVIII
Log: -0.0ms Unloading: Package NWUltraGoreSSEb
Log: -0.0ms Unloading: Package qMenu
Log: -0.0ms Unloading: Package StuffSwapper
NetComeGo: Close DemoRecConnection1 04/21/16 16:54:28
Log: Closing down demo driver.
Log: -0.0ms Unloading: Package UWarMutator
Log: -0.0ms Unloading: Package WindowsLookAndFeel
Log: -0.0ms Unloading: Package EWindow
Log: -0.0ms Unloading: Package XBots9b
Log: Garbage: objects: 35237->29771; refs: 367878
Log: Game class is 'SinglePlayer2'
Log: Level is Level monstertest.MyLevel
Log: Bringing Level monstertest.MyLevel up for play (0)...
ScriptLog: InitGame: ?Name=Player?Class=Botpack.TMale2?team=255?skin=SoldierSkins.blkt?Face=SoldierSkins.Othello?game=oldskool.SinglePlayer2?Mutator=HDSkins.HDSkins_mutator
ScriptLog: Base Mutator is monstertest.spoldskool0
ScriptLog: Mutators HDSkins.HDSkins_mutator
ScriptLog: Add mutator HDSkins.HDSkins_mutator
Critical: appError called:
Critical: Ran out of virtual memory. To prevent this condition, you must free up more space on your primary hard disk.
Critical: Windows GetLastError: Not enough storage is available to process this command. (8)
Exit: Executing UObject::StaticShutdownAfterError
Exit: Executing UWindowsClient::ShutdownAfterError
Exit: UGalaxyAudioSubsystem::ShutdownAfterError
Log: DirectDraw End Mode
Exit: UOpenGLRenderDevice::ShutdownAfterError
Critical: FMallocWindows::Malloc
Critical: FMallocWindows::Realloc
Critical: 00000000 -1709030936 FArray
Critical: FArray::Realloc
Critical: 1396983869*8
Critical: FUnrealfileSummary<<
Critical: LoadSummary
Critical: ULinkerLoad::ULinkerLoad
Critical: UObject::GetPackageLinker
Critical: UObject::StaticLoadObject
Critical: (Core.Class HDSkins.HDSkins_mutator NULL)
Critical: UObject::ProcessEvent
Critical: (SinglePlayer2 monstertest.SinglePlayer0, Function Engine.GameInfo.InitGame)
Critical: BeginPlay
Critical: UGameEngine::LoadMap
Critical: LocalMapURL
Critical: UGameEngine::Browse
Critical: ClientTravel
Critical: UGameEngine::Tick
Critical: UpdateWorld
Critical: MainLoop
Exit: Exiting.
Uninitialized: Name subsystem shut down
Uninitialized: Log file closed, 04/21/16 16:54:31
 



Is anyone else getting this crash, or is this some strange error with my computer only?  No other mutators/mods will crash my game except this one.
  

For High-Res Unreal skins, click here.
Back to top
IP Logged
 
Lightning_Hunter
Senior Member
****
Offline



Posts: 267
Location: somewhere on Earth
Joined: Mar 4th, 2003
Gender: Male
Re: Enhanced Monster Skins
Reply #153 - Apr 22nd, 2016 at 8:16am
Print Post  
Here is the Nali Skin.  Took me a while to get this skin right (especially with 4 messed up hands I had to fix).  Personally, I feel the screenshots do not do the high-res skin justice, but everyone will just have to take my word for it until I release the project.   Tongue

Make sure to click the screenshots to blow them up.




Old:
  

For High-Res Unreal skins, click here.
Back to top
IP Logged
 
sn260591
Full Member
***
Offline



Posts: 111
Location: Russia
Joined: Aug 17th, 2011
Gender: Male
Re: Enhanced Monster Skins
Reply #154 - Apr 22nd, 2016 at 1:51pm
Print Post  
In this case, install a clean version 436 with no mods and try it.
  

Sorry for my bad English
Back to top
 
IP Logged
 
Lightning_Hunter
Senior Member
****
Offline



Posts: 267
Location: somewhere on Earth
Joined: Mar 4th, 2003
Gender: Male
Re: Enhanced Monster Skins
Reply #155 - Apr 22nd, 2016 at 7:15pm
Print Post  
Still crashes.  I installed a fresh copy of UT99 straight from the CD and updated it to 436.  I copied over HDSkins.int, HDSkins.u, and dm-mutator_test.unr.  I started a practice session, enabled the mutator, and selected dm-mutator_test.unr as the map.  It then crashed.  I did not change any settings at all (I even used the default resolution and direct3d drivers).
  

For High-Res Unreal skins, click here.
Back to top
IP Logged
 
Lightning_Hunter
Senior Member
****
Offline



Posts: 267
Location: somewhere on Earth
Joined: Mar 4th, 2003
Gender: Male
Re: Enhanced Monster Skins
Reply #156 - Apr 24th, 2016 at 5:51pm
Print Post  
Can anyone else with UT99 test sn260591's mutator and see if it crashes?  That would help sn260591 know whether or not it is just something odd going on with my computer, or if it's the mutator itself.  I tried a fresh install of UT99, and I still get the crash...
  

For High-Res Unreal skins, click here.
Back to top
IP Logged
 
Ironword
New Member
*
Offline


Oldunreal member

Posts: 25
Joined: Apr 15th, 2016
for gopostal
Reply #157 - May 7th, 2016 at 1:33am
Print Post  
I don't know anything about 3D modeling, but I'm assuming that a basic finished model works on the same principle as a 2D graphic--i.e. that it's saved in some sort of standard format, the 3D equivalent of JPEG or PNG, and that therefore the model can be used by any 3D application for any 3D purpose, the same way both Adobe Illustrator or CorelDraw can open a standard 2D bitmap file and incorporate it into a larger project (poster, flyer, whatever).

If that is the case, this is for gopostal...

gopostal wrote on Mar 5th, 2016 at 11:22am:
My long-time dream is that someone would remodel the stock monsters. I'd handle *everything* else if you can do that. You make a second generation model that looks good and I'll do all the replacement script, animations, texturing, etc. and I'll make them incredible.

If you are serious about this, your dream seems to be happening over at https://www.epicgames.com/unrealtournament/forums/showthread.php?19379-Unreal-Un... . It's going slowly but a couple of modellers having been consistently chipping away for about a year now, and they're still working at it (last post was just about a week-and-a-half ago, so it's still alive). Looks like it'll be a while yet before a complete set is available (if ever), but they're making progress.

So you may wish to get in contact with the modellers and keep tabs on what's going on. Since they're already planning on contributing the models for free to the new UT, I doubt they'd mind allowing us orig-Unrealers to have them too. And if the thread just poops out in, say, another six months, at least you'll have the modellers' contact info so you can siphon off whatever work they did get done. We might only end up with an awesome Brute, Manta, and Krall Elite, and it would be kind of weird seeing them beside our old Skaarjs. But for my money it'd be better than nothing.

And in the meantime, I fully support better skins too! I'm fairly ecumenical on this issue--I'll take whatever eye-candy I can get, from whatever source...
  
Back to top
 
IP Logged
 
Ironword
New Member
*
Offline


Oldunreal member

Posts: 25
Joined: Apr 15th, 2016
Re: Enhanced Monster Skins
Reply #158 - May 7th, 2016 at 2:30am
Print Post  
Lightning_Hunter wrote on Apr 24th, 2016 at 5:51pm:
Can anyone else with UT99 test sn260591's mutator and see if it crashes?  That would help sn260591 know whether or not it is just something odd going on with my computer, or if it's the mutator itself.

Sorry to say, Lightning, looks like it's your machine. I tested it in Oldskool starting original Unreal Game and loaded fine, then went through the Vortex Rikers and automatically loaded Nyleve Falls with no trouble. Got killed by the Brutes and didn't go any further, but at least the skins mutator didn't crash me.
  
Back to top
 
IP Logged
 
gopostal
Betatester
Offline


Hack coder

Posts: 940
Joined: Jul 31st, 2008
Gender: Male
Re: Enhanced Monster Skins
Reply #159 - May 7th, 2016 at 2:46am
Print Post  
Thanks for that link IW. I'm reading it now from the start but I did skip to the end and look at the posted Titan work. It's really good but it may be 'too good' by a long way. That's a ton of polys per monster and there's no way to cheat that. I did a lot of real world testing of medium to higher poly models when I was importing the Killing Floor Christmas monsters and they will bring even a good system's performance down very fast.

Ideally what is needed is something on the level of UT2004's monsters at most. Skeletal mesh but lower poly count so that many multiple monsters can render without stutter or problem.

It's just really easy to forget how ancient this old game is. We expect it to be so much more robust than it's actually capable of being. Honestly I was hoping for something like QTit's model adjustments. Did he ever post the actual how of his changes to the titan model? That's the road to take.
  

I don't want to give the end away
but we're all going to die one day
Back to top
 
IP Logged
 
Lightning_Hunter
Senior Member
****
Offline



Posts: 267
Location: somewhere on Earth
Joined: Mar 4th, 2003
Gender: Male
Re: Enhanced Monster Skins
Reply #160 - May 7th, 2016 at 5:45am
Print Post  
Sorry Ironword, but I believe there will be almost a 0% chance those models will ever appear in UT99/Unreal.  Even if they are completed, I doubt anyone would manage to port them over without completely butchering them.  The animations, polys, etc. would not carry over, and even if they did, the game would not run as gopostal stated.  The models are nice, but I'm certain they will have to remain in a newer UT platform where they belong.

As for the mutator, I have no clue why it is crashing on only my computer... No other mutators/mods are crashing the game, and I am running a ton of them when I play SP or Multiplayer.  I have a 1TB HD with 75% of it free, and 4GB of RAM, so that's not the issue...  Honestly, not being able to test some of my skins without the proper masked textures is slowing down my progress.  Using this mutator would resolve that, but it's not working...  The only Scripted Pawn skin I have not completed is the Queen (I'm not looking forward to it), and the cow skin is half finished.  Meanwhile in real life, work has gotten busy, and I just don't have the spare time to figure out how to get the mutator working.  As a result, progress is at a crawl.
  

For High-Res Unreal skins, click here.
Back to top
IP Logged
 
Ironword
New Member
*
Offline


Oldunreal member

Posts: 25
Joined: Apr 15th, 2016
Re: Enhanced Monster Skins
Reply #161 - May 11th, 2016 at 2:05pm
Print Post  
Quote:
it may be 'too good' by a long way
Oh, well. I did say "I don't know anything about 3D modeling"...

Quote:
No other mutators/mods are crashing the game, and I am running a ton of them
What's really puzzling is that all those mutators apparently aren't causing your  problem. On my system, for example, Operation Stingray works fine until two or three other mods are installed, at which point suddenly it no longer appears in the gametype menu. Another example: I like to use Walldodge and DoubleJumpUT along with RocketsUT in Fun Mode (using the "Wild" option to speed the weapons up), but the RocketsUT mutator nullifies the jumping mutators unless it comes after them on the mutator list. Since the rule is generally that mutators later in the list take precedence--which would mean that it should go before them so that they could take precedence--that problem took me a while to figure out. And a few days ago I installed a couple of mutators that destroyed everything. I still don't know which mutator caused the problem, but UT would no longer start--and all I did was install a few new mutators--no changes to configuration (video, audio, etc.) It wouldn't even start in Safe Mode. However, when I an used earlier backup of UT with fewer mutators, I was able to install all of the offending mutators and run each of them with no trouble (though each to its own separate UT). So the issue arose from some unidentified conflict between mutators.

But since you have already tried a clean install with no other mutators, it's a head-scratcher. Sorry it's such a bottleneck.
  
Back to top
 
IP Logged
 
sn260591
Full Member
***
Offline



Posts: 111
Location: Russia
Joined: Aug 17th, 2011
Gender: Male
Re: Enhanced Monster Skins
Reply #162 - May 11th, 2016 at 4:25pm
Print Post  
Lightning_Hunter, last thing I can imagine - it is a conflict with the software installed on your computer. Start Windows in Safe mode, set SoftDrv in game, and try it.
  

Sorry for my bad English
Back to top
 
IP Logged
 
Lightning_Hunter
Senior Member
****
Offline



Posts: 267
Location: somewhere on Earth
Joined: Mar 4th, 2003
Gender: Male
Re: Enhanced Monster Skins
Reply #163 - May 11th, 2016 at 6:51pm
Print Post  
Quote:
But since you have already tried a clean install with no other mutators, it's a head-scratcher. Sorry it's such a bottleneck.


Yes, that's the odd part.  I ran UT99 with no mods/mutator installed whatsoever, and it still crashed.  On the other hand, I can run dozens of other mods/mutators together and have no issues.  I'll try safe mode when I get the time.
  

For High-Res Unreal skins, click here.
Back to top
IP Logged
 
[]KAOS[]Casey
Developer Team
Betatester
Offline


nedm

Posts: 3200
Joined: Aug 7th, 2011
Gender: Male
Re: Enhanced Monster Skins
Reply #164 - May 11th, 2016 at 7:25pm
Print Post  
Your download may be corrupted.

Looks like we need some MD5s/SHA-*s
  
Back to top
 
IP Logged
 
Page Index Toggle Pages: 1 ... 9 10 [11] 12 13 
Send TopicPrint
Bookmarks: del.icio.us Digg Facebook Google Google+ Linked in reddit StumbleUpon Twitter Yahoo