logo
Main

Forums

Downloads

Unreal-Netiquette

Donate for Oldunreal:
Donate

borderline

Links to our wiki:
Wiki

Walkthrough

Links

Tutorials

Unreal Reference

Usermaps

borderline

Contact us:
Submit News
Page Index Toggle Pages: 1 [2]  Send TopicPrint
Very Hot Topic (More than 25 Replies) ALAudio for Rune - development and links (Read 12021 times)
han
Global Moderator
Unreal Rendering Guru
Developer Team
*****
Offline


Oldunreal member

Posts: 572
Location: Germany
Joined: Dec 10th, 2014
Gender: Male
Re: ALAudio for Rune - development and links
Reply #15 - Oct 4th, 2016 at 7:36pm
Print Post  
I have waited long enough for a PubSrc release for Rune Classic.
  

HX on Mod DB. Revision on Steam. Löffels on Patreon.
Back to top
 
IP Logged
 
han
Global Moderator
Unreal Rendering Guru
Developer Team
*****
Offline


Oldunreal member

Posts: 572
Location: Germany
Joined: Dec 10th, 2014
Gender: Male
Re: ALAudio for Rune - development and links
Reply #16 - Oct 5th, 2016 at 10:21pm
Print Post  
I actually expected that the changes were fairly small compared to the old Rune versions, but they basically made UMusic a stub class, but instead use some music streaming system where the data gets passed in if I got that correct.

For RenDevs they added some sort of instead Frame display, similar to the Bink support changes in X-Com: Enforcer, just that you get the data directly.

I'm working on a makeshift header set for Rune Classic now, UCC and D3DDrv compile and work, OpenGLDrv compiles, but require some fixes, but looks more like it hits just a general problem in the OpenGLDrv as there is also a similiar bug present in Deus Ex when playing conversations. Launcher will be some work regarding Window.h as there is a lot of this odd Win32FunctionX macro shit present which won't work correct win wchar_t as buildin type and besides that is pointless as OS certainly supports Unicode, etc.

Currently trying to get ALAudio running, it builds now, but haven't tested as I just wanted to grab the dependency dlls out of a download here. Cheesy
  

HX on Mod DB. Revision on Steam. Löffels on Patreon.
Back to top
 
IP Logged
 
B.F.
New Member
*
Offline


Oldunreal member

Posts: 7
Location: Russia, Novosibirsk
Joined: Nov 14th, 2007
Gender: Male
Re: ALAudio for Rune - development and links
Reply #17 - Oct 5th, 2016 at 11:55pm
Print Post  
han wrote on Oct 5th, 2016 at 10:21pm:
I actually expected that the changes were fairly small compared to the old Rune versions, but they basically made UMusic a stub class, but instead use some music streaming system where the data gets passed in if I got that correct.

For RenDevs they added some sort of instead Frame display, similar to the Bink support changes in X-Com: Enforcer, just that you get the data directly.

I'm working on a makeshift header set for Rune Classic now, UCC and D3DDrv compile and work, OpenGLDrv compiles, but require some fixes, but looks more like it hits just a general problem in the OpenGLDrv as there is also a similiar bug present in Deus Ex when playing conversations. Launcher will be some work regarding Window.h as there is a lot of this odd Win32FunctionX macro shit present which won't work correct win wchar_t as buildin type and besides that is pointless as OS certainly supports Unicode, etc.

Currently trying to get ALAudio running, it builds now, but haven't tested as I just wanted to grab the dependency dlls out of a download here. Cheesy

If you need tester, I'm here and I'm playing it right now.
  
Back to top
 
IP Logged
 
han
Global Moderator
Unreal Rendering Guru
Developer Team
*****
Offline


Oldunreal member

Posts: 572
Location: Germany
Joined: Dec 10th, 2014
Gender: Male
Re: ALAudio for Rune - development and links
Reply #18 - Oct 6th, 2016 at 12:24am
Print Post  
B.F. wrote on Oct 5th, 2016 at 11:55pm:
If you need tester, I'm here and I'm playing it right now.

Sure, just add me on Steam.
  

HX on Mod DB. Revision on Steam. Löffels on Patreon.
Back to top
 
IP Logged
 
han
Global Moderator
Unreal Rendering Guru
Developer Team
*****
Offline


Oldunreal member

Posts: 572
Location: Germany
Joined: Dec 10th, 2014
Gender: Male
Re: ALAudio for Rune - development and links
Reply #19 - Oct 6th, 2016 at 12:27am
Print Post  
ALAudio is sort of working now, no music support, I still got a crash, which seems temporarily done after I added some more debug output (so it looks like some uninitialized variable or so, and probably rather an ALAudio specific than Header/Rune Classic related problem). I also found an ALAudio is writing in random memory bug, which certainly has implications for other games.

So rudimentary initial support for Rune Classic is now implemented, but it will probably take some time before we do an official release for it.
  

HX on Mod DB. Revision on Steam. Löffels on Patreon.
Back to top
 
IP Logged
 
B.F.
New Member
*
Offline


Oldunreal member

Posts: 7
Location: Russia, Novosibirsk
Joined: Nov 14th, 2007
Gender: Male
Re: ALAudio for Rune - development and links
Reply #20 - Oct 6th, 2016 at 3:12am
Print Post  
han wrote on Oct 6th, 2016 at 12:24am:
B.F. wrote on Oct 5th, 2016 at 11:55pm:
If you need tester, I'm here and I'm playing it right now.

Sure, just add me on Steam.

OK. I send you an invitation.
  
Back to top
 
IP Logged
 
lowenz
Full Member
Betatester
***
Offline


Unreal Veteran

Posts: 239
Location: Berghem Haven
Joined: Dec 28th, 2007
Gender: Male
Re: ALAudio for Rune - development and links
Reply #21 - Oct 6th, 2016 at 8:29pm
Print Post  
Thanks Han!
  

The task is not so much to see what no one has yet seen, but to think what nobody has yet thought, about that which everybody sees - E.S.
Back to top
 
IP Logged
 
han
Global Moderator
Unreal Rendering Guru
Developer Team
*****
Offline


Oldunreal member

Posts: 572
Location: Germany
Joined: Dec 10th, 2014
Gender: Male
Re: ALAudio for Rune - development and links
Reply #22 - Oct 7th, 2016 at 12:09am
Print Post  
The raw audio streaming support is now in and I'm currently wrapping up things with the changed StopSound() interface. Afterwards this should be about whats required for a full Rune Classic support.

I'll probably put out a build of the ALAudio.dll afterwards, so I can get some testing feedback in time and not after Smirftsch does an 'official' release build...

So far so good...
  

HX on Mod DB. Revision on Steam. Löffels on Patreon.
Back to top
 
IP Logged
 
han
Global Moderator
Unreal Rendering Guru
Developer Team
*****
Offline


Oldunreal member

Posts: 572
Location: Germany
Joined: Dec 10th, 2014
Gender: Male
Re: ALAudio for Rune - development and links
Reply #23 - Oct 7th, 2016 at 7:00am
Print Post  
Alright, for copyright, disclaimer, see: http://www.oldunreal.com/cgi-bin/yabb2/YaBB.pl?num=1420982304

Open up your Rune.ini and comment out or delete the original [ALAudio.ALAudioSubsystem] section. Renaming it to ['ALAudio.ALAudioSubsystem] is enough though. You might also want to apply this change to your Default.ini file, so you won't end up in a few months if you deleted your Rune.ini file with unforseen consequences.

Grab *.int and all *.dll files but ALAudio.dll out of http://www.oldunreal.com/betatest/OpenAL_v2.4.7_Rune.7z and place it in Rune Classic\System.

Grab ALAudio.dll for Rune Classic out of http://coding.hanfling.de/ALAudio_RuneClassic_20161007.zip and place it in Rune Classic\System.

Play.

Report if something doesn't work right.
  

HX on Mod DB. Revision on Steam. Löffels on Patreon.
Back to top
 
IP Logged
 
B.F.
New Member
*
Offline


Oldunreal member

Posts: 7
Location: Russia, Novosibirsk
Joined: Nov 14th, 2007
Gender: Male
Re: ALAudio for Rune - development and links
Reply #24 - Oct 7th, 2016 at 9:07am
Print Post  
han wrote on Oct 7th, 2016 at 7:00am:
Alright, for copyright, disclaimer, see: http://www.oldunreal.com/cgi-bin/yabb2/YaBB.pl?num=1420982304

Open up your Rune.ini and comment out or delete the original [ALAudio.ALAudioSubsystem] section. Renaming it to ['ALAudio.ALAudioSubsystem] is enough though. You might also want to apply this change to your Default.ini file, so you won't end up in a few months if you deleted your Rune.ini file with unforseen consequences.

Grab *.int and all *.dll files but ALAudio.dll out of http://www.oldunreal.com/betatest/OpenAL_v2.4.7_Rune.7z and place it in Rune Classic\System.

Grab ALAudio.dll for Rune Classic out of http://coding.hanfling.de/ALAudio_RuneClassic_20161007.zip and place it in Rune Classic\System.

Play.

Report if something doesn't work right.


Thanks.
That fixed the sound mess humanhead guys did.
  
Back to top
 
IP Logged
 
XenophobicSkaarj
New Member
*
Offline


A Simple Tentacle

Posts: 28
Location: Na Pali
Joined: Dec 17th, 2015
Gender: Male
Re: ALAudio for Rune - development and links
Reply #25 - Oct 7th, 2016 at 5:15pm
Print Post  
han wrote on Oct 7th, 2016 at 7:00am:
Alright, for copyright, disclaimer, see: http://www.oldunreal.com/cgi-bin/yabb2/YaBB.pl?num=1420982304

Open up your Rune.ini and comment out or delete the original [ALAudio.ALAudioSubsystem] section. Renaming it to ['ALAudio.ALAudioSubsystem] is enough though. You might also want to apply this change to your Default.ini file, so you won't end up in a few months if you deleted your Rune.ini file with unforseen consequences.

Grab *.int and all *.dll files but ALAudio.dll out of http://www.oldunreal.com/betatest/OpenAL_v2.4.7_Rune.7z and place it in Rune Classic\System.

Grab ALAudio.dll for Rune Classic out of http://coding.hanfling.de/ALAudio_RuneClassic_20161007.zip and place it in Rune Classic\System.

Play.

Report if something doesn't work right.


Finally a working sound fix for the steam version!

Thanks a lot, but I do have to mention a bug: if I start a new game and try to skip the intro cutscene, it crashes the game. If you wait all the way it works fine, tried starting a multiplayer server as well and saving/reloading my game and it works.

Here's what it says on the first line:
Critical: Assertion failed: sizeof(PlayingSounds)<=EffectsChannels
[File:ALAudioSubsystem.cpp] [Line: 3820]
If you need the whole error log, just ask, thanks again for the sound fix though, it was so annoying xD
  
Back to top
 
IP Logged
 
han
Global Moderator
Unreal Rendering Guru
Developer Team
*****
Offline


Oldunreal member

Posts: 572
Location: Germany
Joined: Dec 10th, 2014
Gender: Male
Re: ALAudio for Rune - development and links
Reply #26 - Oct 7th, 2016 at 6:04pm
Print Post  
XenophobicSkaarj wrote on Oct 7th, 2016 at 5:15pm:
Thanks a lot, but I do have to mention a bug: if I start a new game and try to skip the intro cutscene, it crashes the game. If you wait all the way it works fine, tried starting a multiplayer server as well and saving/reloading my game and it works.

Here's what it says on the first line:
Critical: Assertion failed: sizeof(PlayingSounds)<=EffectsChannels
[File:ALAudioSubsystem.cpp] [Line: 3820]
If you need the whole error log, just ask, thanks again for the sound fix though, it was so annoying xD

Eeks, the sanity checks I put in wasnt sane by themself.

Updated build:
http://coding.hanfling.de/ALAudio_RuneClassic_20161007-1.zip
  

HX on Mod DB. Revision on Steam. Löffels on Patreon.
Back to top
 
IP Logged
 
[]KAOS[]Casey
Developer Team
Betatester
Offline


nedm

Posts: 3200
Joined: Aug 7th, 2011
Gender: Male
Re: ALAudio for Rune - development and links
Reply #27 - Oct 7th, 2016 at 9:32pm
Print Post  
The assertion failed about the assertion!
  
Back to top
 
IP Logged
 
han
Global Moderator
Unreal Rendering Guru
Developer Team
*****
Offline


Oldunreal member

Posts: 572
Location: Germany
Joined: Dec 10th, 2014
Gender: Male
Re: ALAudio for Rune - development and links
Reply #28 - Oct 7th, 2016 at 11:59pm
Print Post  
[]KAOS[]Casey wrote on Oct 7th, 2016 at 9:32pm:
The assertion failed about the assertion!

I would rather put it as I didn't pass the sanity check. Smiley
  

HX on Mod DB. Revision on Steam. Löffels on Patreon.
Back to top
 
IP Logged
 
Zeromus75
New Member
*
Offline


Oldunreal member

Posts: 2
Joined: Aug 20th, 2017
Re: ALAudio for Rune - development and links
Reply #29 - Aug 20th, 2017 at 5:16am
Print Post  
Sorry for necro-posting this thread, but has anyone noticed some of the voices are off synch when using this fix? When I was playing the single-player campaign, for some reason the cutscene involving Loki when Ragnar became a monster was very off and the audio was playing faster than usual, the voices not matching at all with the animation of the Loki's dialogue. Has anyone else ran into this problem using this fix?
  
Back to top
 
IP Logged
 
Page Index Toggle Pages: 1 [2] 
Send TopicPrint
Bookmarks: del.icio.us Digg Facebook Google Google+ Linked in reddit StumbleUpon Twitter Yahoo