logo
Main

Forums

Downloads

Unreal-Netiquette

Donate for Oldunreal:
Donate

borderline

Links to our wiki:
Wiki

Walkthrough

Links

Tutorials

Unreal Reference

Usermaps

borderline

Contact us:
Submit News
Page Index Toggle Pages: 1 ... 7 8 [9] 10 11 12 Send TopicPrint
Very Hot Topic (More than 25 Replies) ALAudio for UnrealTournament - development and links (Read 72800 times)
Morpheus2396
New Member
*
Offline


Oldunreal member

Posts: 20
Joined: Mar 13th, 2016
Re: ALAudio for UnrealTournament - development and links
Reply #120 - May 8th, 2016 at 5:04pm
Print Post  
Smirftsch wrote on May 8th, 2016 at 4:18pm:
Guess this means that the number of sources is not the culprit of this issue. Regardless, could you post a logfile?


It's also possible that my system (or my UT) isn't configured correctly - despite I always pay serious attention to installation & configuration...

Do I have to use the OpenAL32.dll provided with the ALAudio package, or may I use the native one from my Windows directory?

@Your request: Yes, of course I can do that! Does UT itself automatically create a log file or do I have to enter a command?

@Current Build: Where is the "UseOriginalUnreal" command? Is it gone? If yes, is there a replacement command?

M2396
  
Back to top
 
IP Logged
 
Smirftsch
Forum Administrator
*****
Offline



Posts: 8012
Location: at home
Joined: Apr 30th, 1998
Gender: Male
Re: ALAudio for UnrealTournament - development and links
Reply #121 - May 8th, 2016 at 5:57pm
Print Post  
it automatically creates a logfile, its in your UnrealTournament/System folder and it's called UnrealTournament.log

You can either paste it here, as code (the # symbol in the menubar) or in something like pastebin .com

UseOriginalUnreal became now obsolete with the new distance attenuation system, there is no replacement for it.
  

Sometimes you have to lose a fight to win the war.
Back to top
WWWICQ  
IP Logged
 
sn260591
Full Member
***
Offline



Posts: 113
Location: Russia
Joined: Aug 17th, 2011
Gender: Male
Re: ALAudio for UnrealTournament - development and links
Reply #122 - May 8th, 2016 at 6:09pm
Print Post  
Smirftsch wrote on May 6th, 2016 at 7:09am:
OpenAL_v2.4.7_UT.7z added. As usual, details on first page.

Now I have a problem: some sounds are becomes too quiet (shooting from a minigun, for example), while others are very loud (shock rifle combo).
  

Sorry for my bad English
Back to top
 
IP Logged
 
[]KAOS[]Casey
Developer Team
Betatester
Offline


nedm

Posts: 3195
Joined: Aug 7th, 2011
Gender: Male
Re: ALAudio for UnrealTournament - development and links
Reply #123 - May 9th, 2016 at 1:08am
Print Post  
HRTF enabled?
  
Back to top
 
IP Logged
 
Smirftsch
Forum Administrator
*****
Offline



Posts: 8012
Location: at home
Joined: Apr 30th, 1998
Gender: Male
Re: ALAudio for UnrealTournament - development and links
Reply #124 - May 9th, 2016 at 5:16am
Print Post  
sn260591 wrote on May 8th, 2016 at 6:09pm:
Smirftsch wrote on May 6th, 2016 at 7:09am:
OpenAL_v2.4.7_UT.7z added. As usual, details on first page.

Now I have a problem: some sounds are becomes too quiet (shooting from a minigun, for example), while others are very loud (shock rifle combo).


Unlike minigun, combo ain't a viewport sound, means, its not "the player itself" causing the effect, which is named "ViewportVolumeIntensity". Try adjusting ViewportVolumeIntensity. Perhaps need to adjust the defaults some more, but I noticed that while stereo speakers usually play this often to loud, a 5.1 setup f.e. seems to reduce volume a lot, so there is maybe no perfect default for this one.
  

Sometimes you have to lose a fight to win the war.
Back to top
WWWICQ  
IP Logged
 
sn260591
Full Member
***
Offline



Posts: 113
Location: Russia
Joined: Aug 17th, 2011
Gender: Male
Re: ALAudio for UnrealTournament - development and links
Reply #125 - May 9th, 2016 at 6:36am
Print Post  
Quote:
HRTF enabled?

No, it is off.

Quote:
Unlike minigun, combo ain't a viewport sound, means, its not "the player itself" causing the effect, which is named "ViewportVolumeIntensity". Try adjusting ViewportVolumeIntensity. Perhaps need to adjust the defaults some more, but I noticed that while stereo speakers usually play this often to loud, a 5.1 setup f.e. seems to reduce volume a lot, so there is maybe no perfect default for this one.

Yes, I have a stereo. I set ViewportVolumeIntensity to 1, but it isn't enough. Values more than 1 don't give changes.
  

Sorry for my bad English
Back to top
 
IP Logged
 
Smirftsch
Forum Administrator
*****
Offline



Posts: 8012
Location: at home
Joined: Apr 30th, 1998
Gender: Male
Re: ALAudio for UnrealTournament - development and links
Reply #126 - May 9th, 2016 at 7:14am
Print Post  
that's a bit confusing right now, since 1.0 means no attenuation at all and shouldn't differ in any way to what we had before...although maybe the problem is the combo, not the viewport volume. Some things, like the combo are having almost insane gain but I avoided to clamp it in any way, to be able to have the full range of all sounds used in Unreal/UT.
Additionally I had to limit the listener gain to avoid the compression effect, but this is the case for all sounds, so this shouldn't be the reason.
mmh....
is your speaker setup (in windows) set to stereo as well? Maybe I need to test with my laptop again to compare.
  

Sometimes you have to lose a fight to win the war.
Back to top
WWWICQ  
IP Logged
 
Morpheus2396
New Member
*
Offline


Oldunreal member

Posts: 20
Joined: Mar 13th, 2016
Re: ALAudio for UnrealTournament - development and links
Reply #127 - May 9th, 2016 at 5:57pm
Print Post  
Smirftsch wrote on May 8th, 2016 at 5:57pm:
UseOriginalUnreal became now obsolete with the new distance attenuation system, there is no replacement for it.


Is there any way to adjust the distance sound system to the own taste? Since v2.2 the "sound atmosphere" (sound intensity and/or density - the "feel" of the general skirmish / the "feel" of the general battle sounds) is significantly less "direct"/"loud"/"hardcore" like it was with the original ALAudio version (the One supplied with OMP UTPatch 0.2) or the standard Galaxy Audio Renderer.

And since the latest version (2.4.7) UT sometimes almost sounds like UT2003 - the "sound atmosphere" is much less dense (which is one of the reasons, why I never could get a "feel"/"adrenaline rush" from UT2003 - the sounds are too distant (or simply too quiet) and the frequency of the general battle sounds (= sound density) is lower than original UT), sounds are too distant (not "direct"/"nearby" enough) or simply to quiet.

But the latter (quiet sounds) is way less frustrating than the former (sound density). The sound density is one of THE hallmarks of the "UT Feeling", which I always favored to the "empty sound atmosphere" of UT2003. Don't get me wrong - I don't want to criticize your hard work! I'm just trying to make a point: the new sound distance model may sound more realistic and/or precise, but it doesn't sound better (at least for my taste). The original sound density of UT may sound unrealistic, but it has a major contribution to the "UT feeling". The best idea would be, to improve the realism of the sound distance model while still maintaining the original sound atmosphere/density of UT Wink


About the recent sound bugs and your logfile request:

I completely reinstalled my sound driver (total and clean uninstall, then clean reinstall, clean uninstall of OpenAL, then clean reinstall of OpenAL, clean uninstall of ALchemy, then clean reinstall of ALchemy) and after meticulous configuring and checking it, I gave UT another go. Well, in addition to the sound skipping bug, a new sound bug stepped in:

After first starting UT, I start the first Botmatch (DM with 7 bots in DM-Phobos). As usually, the first ~ 5-10 minutes everything is fine (no sound bugs), then the sound skipping bug occurs and a couple of minutes later, the ingame music (background music) suddenly and completely shuts off for the rest of the match. Then I chose another map (DM-Agony) for the second botmatch in the practise section and again, the sound skipping bug wasn't there the first ~ 5 minutes, but this time, the ingame music shut off after just ~ 30 seconds! I could reproduce this behaviour for DM-Codex in my second UT session (in my first session I switched from DM-Phobos to DM-Agony; later the day in my second UT session I switched to DM-Codex) - in contrast to the first botmatch (DM-Phobos, music shuts off after ~ 10 minutes), in the second botmatch (DM-Codex) ingame music shuts off almost immediately (~ 30 seconds)!

I hope this description is detailed enough for an error analysis...   


And here's the logfile You requested:

Code
Select All
Log: Log file open, 05/09/16 03:49:53
Init: Name subsystem initialized
Init: Detected: Microsoft Windows NT 6.1 (Build: 7601)
Init: Version: 436
Init: Compiled: Oct 24 2000 23:40:18
Init: Command line:
Init: Base directory: D:\UnrealTournament\System\
Init: Character set: Unicode
Log: Bound to Engine.dll
Log: Bound to Core.dll
Log: Bound to Window.dll
Init: Object subsystem initialized
Init: Computer: [COMPUTERNAME]
Init: User: Morpheus2396
Init: Memory total: Phys=4194303K Pagef=4194303K Virt=2097024K
Init: Working set: 32000 / 159000
Init: CPU Speed=3492.122425 MHz
Init: CPU Page size=4096, Processors=8
Init: CPU Detected: PentiumPro-class processor (GenuineIntel)
Init: CPU Features: CMov FPU RDTSC PAE MMX KNI
Init: Unreal engine initialized
Log: Bound to WinDrv.dll
Init: Mouse info: 0 0 0
Init: Initializing DirectDraw
Log: DirectDraw drivers:
Log:    display (Primärer Anzeigetreiber)
Init: DirectDraw initialized successfully
Init: DirectInput initialized successfully.
Init: Client initialized
Log: Bound to Render.dll
Init: Lighting subsystem initialized
Init: Rendering initialized
Log: LoadMap: Entry
Log: Bound to Fire.dll
Log: Bound to IpDrv.dll
Log: Game class is 'UTIntro'
Log: Level is Level Entry.MyLevel
Log: Bringing Level Entry.MyLevel up for play (0)...
ScriptLog: InitGame:
ScriptLog: Base Mutator is Entry.Mutator0
Log: Browse: CityIntro.unr?Name=Morpheus2396?Class=SkeletalChars.WarBoss?team=255?skin=?Face=?Voice=
Log: LoadMap: CityIntro.unr?Name=Morpheus2396?Class=SkeletalChars.WarBoss?team=255?skin=?Face=?Voice=
Log: Collecting garbage
Log: Purging garbage
Log: -0.0ms Unloading: Package Render
Log: Garbage: objects: 16408->16407; refs: 224634
Log: Game class is 'UTIntro'
Log: Level is Level CityIntro.MyLevel
Log: Bringing Level CityIntro.MyLevel up for play (0)...
ScriptLog: InitGame: ?Name=Morpheus2396?Class=SkeletalChars.WarBoss?team=255?skin=?Face=?Voice=
ScriptLog: Base Mutator is CityIntro.Mutator1
Init: Initialized moving brush tracker for Level CityIntro.MyLevel
Log: Bound to UWeb.dll
ScriptLog: Team 255
ScriptLog: Login: Morpheus2396
Log: Possessed PlayerPawn: WarBoss CityIntro.WarBoss0
Init: Input system initialized for WindowsViewport0
Log: Opened viewport
Log: Bound to OpenGLDrv.dll
Log: Initializing OpenGLDrv...
Log: Enter SetRes()
Init: Using pixel format 7
Init: GL_VENDOR     : NVIDIA Corporation
Init: GL_RENDERER   : GeForce GTX 770/PCIe/SSE2
Init: GL_VERSION    : 4.5.0 NVIDIA 364.72
Init: Device supports: GL_EXT_bgra
Init: Device supports: GL_ARB_texture_compression
Init: Device supports: GL_EXT_texture_compression_s3tc
Init: Device supports: GL_EXT_texture_env_combine
Init: Device supports: GL_ARB_texture_env_combine
Init: Device supports: GL_EXT_texture_filter_anisotropic
Init: Device supports: GL_NV_texture_env_combine4
Init: Device supports: GL_EXT_texture_lod_bias
Init: Device supports: GL_EXT_secondary_color
Init: Device supports: GL_ARB_multitexture
Init: Device supports: GL_EXT_multi_draw_arrays
Init: Device supports: GL_ARB_vertex_program
Init: Device supports: GL_ARB_fragment_program
Init: Depth bits: 24
Log: 4 Texture Mapping Units found
Log: Trying to use S3TC extension.
Log: MinLogTextureSize: 2
Log: MaxLogTextureSize: 14
Log: BufferActorTris: 1
Log: UseDetailAlpha: 1
Log: Bound to ALAudio.dll
Log: ALAudio.ALAudioSubsystem.ALDevices
Log: ALAudio: ALDEVICES found 0:SBXFiAudio0001
Log: ALAudio: ALDEVICES found 1:OpenALSoftonLautsprecherCreativeSBXFi
Log: ALAudio: ALDEVICES found 2:OpenALSoftonSPDIFOutCreativeSBXFi
Log: ALAudio: ALDEVICES found 3:OpenALSoftonDigitalaudioHDMICreativeSBXFi
Log: ALAudio: ALDEVICES found 4:GenericSoftwareonLautsprecherCreativeSBXFi
Log: ALAudio: ALDEVICES found 5:GenericSoftwareonSPDIFOutCreativeSBXFi
Warning: Failed to load Filter Object Management Functions.
Init: ALAudio: Selected ALDevice 0, OutputRateNum 5(44100 Hz) SampleRateNum 5 (44100 Hz)
DevAudio: ALAudio: Trying to use default device
Init: ALAudio: We are using OpenAL device: SB X-Fi Audio [0001]
Init: ALAudio: Can't set OutputRate of 44100, using system (OS) defaults of 48000.
Some backends don't support setting custom rates for specific applications (MMDevAPI or ALSA without dmix).
In this case setting something higher than what the system is outputting is unnecessary since it's just going to be downsampled for output anyway,
and setting it lower is just going to make it get upsampled after OpenAL Soft has already applied its filters and effects.
Adjust your system settings instead.
Init: ALAudio: Audio hardware supports 126 mono (usually sound) and 1 stereo (usually music) sources.
Init: ALAudio: Reducing EffectsChannels to 126 sources.
Init: ALAudio: auto matched SampleRate (48000 Hz) to OutputRate (48000 Hz).
Init: ALAudio: HRTF is disabled.
DevAudio: ALAudio: Initialized with rate 48000
DevAudio: ALAudio: Using OutputRate of 48000 Hz for audio output
DevAudio: ALAudio: Using SampleRate of 48000 Hz for libxmp
Warning: Couldn't set distance units
Warning: No OpenALSoft extensions present!
Init: OpenAL Effects extension version 1.0 found.
Init: ALAudio: EFX initialized.
DevAudio: Successfully loaded OpenAL Effects Extension functions.
Init: ALAudio: Version OpenAL version 1.1 found
Init: ALAudio subsystem initialized.
Init: Game engine initialized
Log: Startup time: 1.075095 seconds
DevMusic: ALAudio: Transiting to Uttitle, SongSection 0 with MTRAN 3
DevMusic: RegisterMusic Uttitle
Log: ALAudio: playing Uttitle Unreal Tournament Title (Impulse Tracker 2.14v5 IT 1.00)
Log: URL: Adding default option Name=Morpheus2396
Log: URL: Adding default option Class=SkeletalChars.WarBoss
Log: URL: Adding default option team=255
Log: URL: Adding default option skin=
Log: URL: Adding default option Face=
Log: URL: Adding default option Voice=
Log: Browse: Index.unr?entry?Name=Morpheus2396?Class=SkeletalChars.WarBoss?team=255?skin=?Face=?Voice=
Log: Failed; returning to Entry
Init: Shut down moving brush tracker for Level CityIntro.MyLevel
Log: Spawning new actor for Viewport WindowsViewport0
ScriptLog: Team 255
ScriptLog: Login: Morpheus2396
Log: Possessed PlayerPawn: WarBoss Entry.WarBoss1
DevMusic: ALAudio: Unregister music: Music Uttitle.Uttitle
DevMusic: ALAudio: Transiting to None with MTRAN 3
ScriptLog: Creating root window: UMenu.UMenuRootWindow
ScriptWarning: CDDecals Transient.UMenuMenuBar0.CDDecals0 (Function DecalStay.CDDecals.Setup:001F) Accessed None
ScriptWarning: CDDecals Transient.UMenuMenuBar0.CDDecals0 (Function DecalStay.CDDecals.Setup:0027) Accessed None
ScriptWarning: CDDecals Transient.UMenuMenuBar0.CDDecals0 (Function DecalStay.CDDecals.Setup:0030) Accessed None
ScriptWarning: CDDecals Transient.UMenuMenuBar0.CDDecals0 (Function DecalStay.CDDecals.Setup:0042) Accessed None
ScriptWarning: CDDecals Transient.UMenuMenuBar0.CDDecals0 (Function DecalStay.CDDecals.Setup:004A) Attempt to assigned variable through None
ScriptWarning: CDDecals Transient.EWindowModMenu0.CDDecals1 (Function DecalStay.CDDecals.Setup:001F) Accessed None
ScriptWarning: CDDecals Transient.EWindowModMenu0.CDDecals1 (Function DecalStay.CDDecals.Setup:0027) Accessed None
ScriptWarning: CDDecals Transient.EWindowModMenu0.CDDecals1 (Function DecalStay.CDDecals.Setup:0030) Accessed None
ScriptWarning: CDDecals Transient.EWindowModMenu0.CDDecals1 (Function DecalStay.CDDecals.Setup:0042) Accessed None
ScriptWarning: CDDecals Transient.EWindowModMenu0.CDDecals1 (Function DecalStay.CDDecals.Setup:004A) Attempt to assigned variable through None
DevMusic: ALAudio: Transiting to utmenu23, SongSection 0 with MTRAN 3
DevMusic: RegisterMusic utmenu23
Log: ALAudio: playing utmenu23 Unreal Tournament Menu (Impulse Tracker 2.14v5 IT 1.00)
Log: URL: Adding default option Name=Morpheus2396
Log: URL: Adding default option Class=SkeletalChars.WarBoss
Log: URL: Adding default option team=255
Log: URL: Adding default option skin=
Log: URL: Adding default option Face=
Log: URL: Adding default option Voice=
Log: Browse: DM-Phobos.unr?Game=BotPack.DeathMatchPlus?Mutator=XMaps.XMapsControl?Name=Morpheus2396?Class=SkeletalChars.WarBoss?team=255?skin=?Face=?Voice=
Log: LoadMap: DM-Phobos.unr?Game=BotPack.DeathMatchPlus?Mutator=XMaps.XMapsControl?Name=Morpheus2396?Class=SkeletalChars.WarBoss?team=255?skin=?Face=?Voice=
DevMusic: ALAudio: Unregister music: Music utmenu23.utmenu23
Log: Collecting garbage
Log: Purging garbage
Log: -0.0ms Unloading: Package CityIntro
Log: -0.0ms Unloading: Package city
Log: -0.0ms Unloading: Package ArenaTex
Log: -0.0ms Unloading: Package NaliCast
Log: -0.0ms Unloading: Package RainFX
Log: -0.0ms Unloading: Package NaliFX
Log: -0.0ms Unloading: Package ShaneSky
Log: -0.0ms Unloading: Package AmbAncient
Log: -0.0ms Unloading: Package AmbOutside
Log: -0.0ms Unloading: Package Uttitle
Log: -0.0ms Unloading: Package openingwave
Log: -0.0ms Unloading: Package Chaosgames
Log: -0.0ms Unloading: Package ChaosUT
Log: -0.0ms Unloading: Package chaostex
Log: -0.0ms Unloading: Package ChaosSounds
Log: -0.0ms Unloading: Package chaossounds2
Log: -0.0ms Unloading: Package ChaosUTMedia1
Log: -0.0ms Unloading: Package ChaosUTMedia5
Log: -0.0ms Unloading: Package ChaosUTMedia2
Log: -0.0ms Unloading: Package chaostex2
Log: -0.0ms Unloading: Package ChaosUTMedia4
Log: -0.0ms Unloading: Package ChaosUTMedia3
Log: -0.0ms Unloading: Package chaos_special_tex
Log: -0.0ms Unloading: Package ChaosUTMiscMuts
Log: -0.0ms Unloading: Package EavyAssaultPractice
Log: -0.0ms Unloading: Package RocketArena
Log: -0.0ms Unloading: Package RocketArenaMedia
Log: -0.0ms Unloading: Package DM-Agony
Log: -0.0ms Unloading: Package UTcrypt
Log: -0.0ms Unloading: Package Indus6
Log: -0.0ms Unloading: Package Crypt2
Log: -0.0ms Unloading: Package shanechurch
Log: -0.0ms Unloading: Package skybox
Log: -0.0ms Unloading: Package DoorsAnc
Log: -0.0ms Unloading: Package Course
Log: Garbage: objects: 33270->25622; refs: 363835
Log: Game class is 'DeathMatchPlus'
Log: Level is Level DM-Phobos.MyLevel
Log: Bringing Level DM-Phobos.MyLevel up for play (0)...
ScriptLog: InitGame: ?Game=BotPack.DeathMatchPlus?Mutator=XMaps.XMapsControl?Name=Morpheus2396?Class=SkeletalChars.WarBoss?team=255?skin=?Face=?Voice=
ScriptLog: Base Mutator is DM-Phobos.DMMutator0
ScriptLog: Mutators XMaps.XMapsControl
ScriptLog: Add mutator XMaps.XMapsControl
XMapsControl: XMaps Server 231, (c) touchstone@planetunreal.com 2003
XMapsUL3: Initialise: game class Botpack.DeathMatchPlus, mode 2, use favourites is True
XMapsControl: LoadMutators: no XMaps Mutator List configured for Tournament DeathMatch
XMapsControl: LoadMutators: no XMaps Mutator List configured for 'Morpheus-2396's Deathmatch'
ScriptLog: Initiating local logging...
Log: Spawning new actor for Viewport WindowsViewport0
ScriptLog: Team 255
ScriptLog: Login: Morpheus2396
Log: Possessed PlayerPawn: WarBoss DM-Phobos.WarBoss2
Init: Initialized moving brush tracker for Level DM-Phobos.MyLevel
DevMusic: ALAudio: Transiting to Botmca9, SongSection 0 with MTRAN 3
DevMusic: RegisterMusic Botmca9
Log: ALAudio: playing Botmca9 BOTPACK #9(By Michiel) (Impulse Tracker 2.14 IT 2.00)
Warning: ALAudio: Musicbuffer error: Invalid enum parameter passed as an argument to an AL call.
DevMusic: ALAudio: Unregister music: Music Botmca9.Botmca9
DevMusic: RegisterMusic Botmca9
Warning: Failed to load 'Package0': Can't find file for package 'Package0'
Warning: Failed to load 'Texture Package0.Screenshot': Can't find file for package 'Package0'
Warning: Failed to load 'Package1': Can't find file for package 'Package1'
Warning: Failed to load 'LevelSummary Package1.LevelSummary': Can't find file for package 'Package1'
Log: URL: Adding default option Name=Morpheus2396
Log: URL: Adding default option Class=SkeletalChars.WarBoss
Log: URL: Adding default option team=255
Log: URL: Adding default option skin=
Log: URL: Adding default option Face=
Log: URL: Adding default option Voice=
Log: Browse: DM-Codex.unr?Game=BotPack.DeathMatchPlus?Mutator=XMaps.XMapsControl?Name=Morpheus2396?Class=SkeletalChars.WarBoss?team=255?skin=?Face=?Voice=
Log: LoadMap: DM-Codex.unr?Game=BotPack.DeathMatchPlus?Mutator=XMaps.XMapsControl?Name=Morpheus2396?Class=SkeletalChars.WarBoss?team=255?skin=?Face=?Voice=
DevMusic: ALAudio: Unregister music: Music Botmca9.Botmca9
Init: Shut down moving brush tracker for Level DM-Phobos.MyLevel
Log: Collecting garbage
Log: Purging garbage
Log: -0.0ms Unloading: Package DecayedS
Log: -0.0ms Unloading: Package GenIn
Log: -0.0ms Unloading: Package AmbModern
Log: -0.0ms Unloading: Package ChaosUTMiscMuts
Log: -0.0ms Unloading: Package chaos_special_tex
Log: -0.0ms Unloading: Package ChaosUTMedia3
Log: -0.0ms Unloading: Package ChaosUTMedia4
Log: -0.0ms Unloading: Package chaostex2
Log: -0.0ms Unloading: Package ChaosUTMedia1
Log: -0.0ms Unloading: Package Chaosgames
Log: -0.0ms Unloading: Package chaossounds2
Log: -0.0ms Unloading: Package ChaosSounds
Log: -0.0ms Unloading: Package ChaosUTMedia2
Log: -0.0ms Unloading: Package ChaosUT
Log: -0.0ms Unloading: Package ChaosUTMedia5
Log: -0.0ms Unloading: Package chaostex
Log: -0.0ms Unloading: Package FCommandoSkins
Log: -0.0ms Unloading: Package SoldierSkins
Log: -0.0ms Unloading: Package SGirlSkins
Log: -0.0ms Unloading: Package CommandoSkins
Log: -0.0ms Unloading: Package XMapsClient231
Log: -0.0ms Unloading: Package XMaps
Log: -0.0ms Unloading: Package DM-Phobos
Log: -0.0ms Unloading: Package XbpFX
Log: -0.0ms Unloading: Package XFX
Log: -0.0ms Unloading: Package Palettes
Log: -0.0ms Unloading: Package SkyCity
Log: -0.0ms Unloading: Package DoorsMod
Log: -0.0ms Unloading: Package Activates
Log: -0.0ms Unloading: Package noxxsnd
Log: -0.0ms Unloading: Package Botmca9
Log: -0.0ms Unloading: Package EavyAssaultPractice
Log: -0.0ms Unloading: Package RocketArena
Log: -0.0ms Unloading: Package RocketArenaMedia
Log: Garbage: objects: 37584->25319; refs: 600538
Log: Game class is 'DeathMatchPlus'
Log: Level is Level DM-Codex.MyLevel
Log: Bringing Level DM-Codex.MyLevel up for play (0)...
ScriptLog: InitGame: ?Game=BotPack.DeathMatchPlus?Mutator=XMaps.XMapsControl?Name=Morpheus2396?Class=SkeletalChars.WarBoss?team=255?skin=?Face=?Voice=
ScriptLog: Base Mutator is DM-Codex.DMMutator1
ScriptLog: Mutators XMaps.XMapsControl
ScriptLog: Add mutator XMaps.XMapsControl
XMapsControl: XMaps Server 231, (c) touchstone@planetunreal.com 2003
XMapsUL3: Initialise: game class Botpack.DeathMatchPlus, mode 2, use favourites is True
XMapsControl: LoadMutators: no XMaps Mutator List configured for Tournament DeathMatch
XMapsControl: LoadMutators: no XMaps Mutator List configured for 'Morpheus-2396's Deathmatch'
ScriptLog: Initiating local logging...
Log: Spawning new actor for Viewport WindowsViewport0
ScriptLog: Team 255
ScriptLog: Login: Morpheus2396
Log: Possessed PlayerPawn: WarBoss DM-Codex.WarBoss3
Init: Initialized moving brush tracker for Level DM-Codex.MyLevel
DevMusic: ALAudio: Transiting to Mission, SongSection 0 with MTRAN 3
DevMusic: RegisterMusic Mission
Log: ALAudio: playing Mission Mission Landing (ModPlug Tracker 1.16 IT 1.00)
Warning: ALAudio: Musicbuffer error: Invalid enum parameter passed as an argument to an AL call.
DevMusic: ALAudio: Unregister music: Music Mission.Mission
Warning: ALAudio: UnregisterMusic alDeleteSources error: Invalid enum parameter passed as an argument to an AL call.
DevMusic: RegisterMusic Mission
Log: appRequestExit(0)
Exit: Preparing to exit.
Log: Purging garbage
Log: Unbound to Engine.dll
Log: Unbound to Core.dll
Log: Unbound to Window.dll
Log: -0.0ms Unloading: Package Engine
Log: -0.0ms Unloading: Package Core
Exit: Game engine shut down
Log: Unbound to WinDrv.dll
Log: DirectDraw End Mode
Log: Flushing cache
Exit: DirectDraw released
Exit: Windows client shut down
Log: Unbound to Render.dll
Exit: Lighting subsystem shut down
Exit: Rendering shut down
Log: -0.0ms Unloading: Package Entry
Log: -0.0ms Unloading: Package Logo
Log: Unbound to Fire.dll
Log: -0.0ms Unloading: Package Fire
Log: -0.0ms Unloading: Package credits
Log: -0.0ms Unloading: Package Botpack
Log: -0.0ms Unloading: Package UnrealShare
Log: -0.0ms Unloading: Package UnrealI
Log: -0.0ms Unloading: Package Female2Voice
Log: -0.0ms Unloading: Package Male2Voice
Log: -0.0ms Unloading: Package Female1Voice
Log: -0.0ms Unloading: Package BossVoice
Log: -0.0ms Unloading: Package Male1Voice
Log: -0.0ms Unloading: Package UMenu
Log: -0.0ms Unloading: Package UWindow
Log: -0.0ms Unloading: Package UBrowser
Log: Unbound to IpDrv.dll
Log: -0.0ms Unloading: Package IpDrv
Log: -0.0ms Unloading: Package Announcer
Log: -0.0ms Unloading: Package Detail
Log: -0.0ms Unloading: Package GenFX
Log: -0.0ms Unloading: Package genfluid
Log: -0.0ms Unloading: Package UTMenu
Log: -0.0ms Unloading: Package LadderSounds
Log: Unbound to UWeb.dll
Log: -0.0ms Unloading: Package UWeb
Log: -0.0ms Unloading: Package UTServerAdmin
Log: -0.0ms Unloading: Package IpServer
Log: -0.0ms Unloading: Package LadrArrow
Log: -0.0ms Unloading: Package SkeletalChars
Log: Unbound to OpenGLDrv.dll
Log: Unbound to ALAudio.dll
DevMusic: ALAudio: Unregister music: Music Mission.Mission
DevMusic: WaitForThread failed with No error (Errorcode 0)!
Exit: ALAudio: libxmp subsystem shut down.
Exit: ALAudio: Audio subsystem shut down.
Log: -0.0ms Unloading: Package LadderFonts
Log: -0.0ms Unloading: Package UWindowFonts
Log: -0.0ms Unloading: Package AimTrainer
Log: -0.0ms Unloading: Package DecalStay
Log: -0.0ms Unloading: Package Excessive
Log: -0.0ms Unloading: Package MultiMesh
Log: -0.0ms Unloading: Package EpicCustomModels
Log: -0.0ms Unloading: Package UTBrowser
Log: -0.0ms Unloading: Package MoreGore
Log: -0.0ms Unloading: Package SpreeBonus
Log: -0.0ms Unloading: Package ModMenuExtension
Log: -0.0ms Unloading: Package EWindow
Log: -0.0ms Unloading: Package WeaponPriority
Log: -0.0ms Unloading: Package EnhancedItems
Log: -0.0ms Unloading: Package utmenu23
Log: -0.0ms Unloading: Package UTtech1
Log: -0.0ms Unloading: Package FCommandoSkins
Log: -0.0ms Unloading: Package CommandoSkins
Log: -0.0ms Unloading: Package SoldierSkins
Log: -0.0ms Unloading: Package SGirlSkins
Log: -0.0ms Unloading: Package XMapsClient231
Log: -0.0ms Unloading: Package XMaps
Log: -0.0ms Unloading: Package DM-Codex
Log: -0.0ms Unloading: Package utcrypt
Log: -0.0ms Unloading: Package Indus6
Log: -0.0ms Unloading: Package Crypt2
Log: -0.0ms Unloading: Package Ancient
Log: -0.0ms Unloading: Package NaliCast
Log: -0.0ms Unloading: Package SKYBox
Log: -0.0ms Unloading: Package DoorsAnc
Log: -0.0ms Unloading: Package ShaneSky
Log: -0.0ms Unloading: Package Ambancient
Log: -0.0ms Unloading: Package uttech2
Log: -0.0ms Unloading: Package hubeffects
Log: -0.0ms Unloading: Package AmbOutside
Log: -0.0ms Unloading: Package Liquids
Log: -0.0ms Unloading: Package shaneDAY
Log: -0.0ms Unloading: Package Mission
Init: Shut down moving brush tracker for Level DM-Codex.MyLevel
Log: Garbage: objects: 30090->0; refs: 600538
Exit: Object subsystem successfully closed.
Exit: Exiting.
Uninitialized: Name subsystem shut down
Uninitialized: Memory Allocation Status
Uninitialized: Curr Memory  2.243M /  0.926M
Uninitialized: Peak Memory  115.510M /  115.762M
Uninitialized: Allocs          50 Current /  8835550 Total
Uninitialized: Log file closed, 05/09/16 03:59:38
 



Thx,

M2396
  
Back to top
 
IP Logged
 
Morpheus2396
New Member
*
Offline


Oldunreal member

Posts: 20
Joined: Mar 13th, 2016
Re: ALAudio for UnrealTournament - development and links
Reply #128 - May 9th, 2016 at 6:13pm
Print Post  
[]KAOS[]Casey wrote on May 9th, 2016 at 1:08am:
HRTF enabled?


Is HRTF required for the native (Creative's implementation, HW-accelerated) OpenAL driver in order to enable 3D-Sound for Headphones?

I use the native OpenAL driver (not OpenALSoft) with CMSS-3D HP when playing through my headphones - but ALchemy is disabled (of course).

M2396
  
Back to top
 
IP Logged
 
Smirftsch
Forum Administrator
*****
Offline



Posts: 8012
Location: at home
Joined: Apr 30th, 1998
Gender: Male
Re: ALAudio for UnrealTournament - development and links
Reply #129 - May 10th, 2016 at 6:52am
Print Post  
First, thank you for this feedback. About the critics, I am only really pissed if I read something like "it's all crap and sh!t because it didn't work or whatever", especially in 3rd party forums or if people don't take 5 minutes of time to check out some things or to try with the settings but complain like 20 pages somewhere. All fine Smiley

I didn't think that someone would miss the old system, indeed, since the new system sounds way more consistent and offers now a few more options also to adjust the sound and intensity to personal needs. I also avoided to clamp anything to keep the original scale and range of sound volumes. Mmh...guess I'll have to see how and if the "original" system can be kept as an alternative then.

Now about the log, yes, that reveals quite some Smiley

As for your sound problems, I smell an interaction - and this is something I really can't predict or estimate, perhaps with ALChemy. It's something I can't take into account from the coding side. Did you also try it entirely without it?
OR there is possibly some other mixup:

Quote:
Log: ALAudio.ALAudioSubsystem.ALDevices
Log: ALAudio: ALDEVICES found 0:SBXFiAudio0001
Log: ALAudio: ALDEVICES found 1:OpenALSoftonLautsprecherCreativeSBXFi
Log: ALAudio: ALDEVICES found 2:OpenALSoftonSPDIFOutCreativeSBXFi
Log: ALAudio: ALDEVICES found 3:OpenALSoftonDigitalaudioHDMICreativeSBXFi
Log: ALAudio: ALDEVICES found 4:GenericSoftwareonLautsprecherCreativeSBXFi
Log: ALAudio: ALDEVICES found 5:GenericSoftwareonSPDIFOutCreativeSBXFi


Because I am really surprised about this: OpenALSofton... - which shouldn't be there if you are using Creative Labs dll.

It should rather look like this (now I have 2 soundcards, but you'll get the idea)

Quote:
Log: ALAudio.ALAudioSubsystem.ALDevices
Log: ALAudio: ALDEVICES found 0:DirectSoundDefault
Log: ALAudio: ALDEVICES found 1:SpeakersCreativeSBXFiviaDirectSound
Log: ALAudio: ALDEVICES found 2:SPDIFOutCreativeSBXFiviaDirectSound
Log: ALAudio: ALDEVICES found 3:RealtekDigitalOutputRealtekHighDefinitionAudioviaDirectSound
Log: ALAudio: ALDEVICES found 4:RealtekDigitalOutputOpticalRealtekHighDefinitionAudioviaDirectSound
Log: ALAudio: ALDEVICES found 5:WaveOutDefault
Log: ALAudio: ALDEVICES found 6:SpeakersCreativeSBXFiviaWaveOut
Log: ALAudio: ALDEVICES found 7:SPDIFOutCreativeSBXFiviaWaveOut
Log: ALAudio: ALDEVICES found 8:RealtekDigitalOutputRealtekviaWaveOut
Log: ALAudio: ALDEVICES found 9:RealtekDigitalOutputOpticalviaWaveOut
Log: ALAudio: ALDEVICES found 10:NoOutput
Log: ALAudio: ALDEVICES found 11:GenericSoftwareonSpeakersCreativeSBXFi


Now getting to music:
Quote:
Warning: ALAudio: Musicbuffer error: Invalid enum parameter passed as an argument to an AL call.
DevMusic: ALAudio: Unregister music: Music Botmca9.Botmca9

Unfortunately this is sort of generic error, but I very much assume that the buffering thread either died or hangs. Could it be possible by any chance that you limit UT to run on one CPU core only? This could be a reason.

PS: HRTF only works on OpenALSoft, it doesn't work on Creatives dll.
  

Sometimes you have to lose a fight to win the war.
Back to top
WWWICQ  
IP Logged
 
Morpheus2396
New Member
*
Offline


Oldunreal member

Posts: 20
Joined: Mar 13th, 2016
Re: ALAudio for UnrealTournament - development and links
Reply #130 - May 10th, 2016 at 8:15am
Print Post  
Smirftsch wrote on May 10th, 2016 at 6:52am:
I didn't think that someone would miss the old system, indeed, since the new system sounds way more consistent and offers now a few more options also to adjust the sound and intensity to personal needs. I also avoided to clamp anything to keep the original scale and range of sound volumes. Mmh...guess I'll have to see how and if the "original" system can be kept as an alternative then.


Maybe I could be wrong - I should test the new distance model a little bit more. I didn't have more time to test it thoroughly enough... (and I won't have for the next days, because I'll be out of home...)


Smirftsch wrote on May 10th, 2016 at 6:52am:
Now about the log, yes, that reveals quite some Smiley

As for your sound problems, I smell an interaction - and this is something I really can't predict or estimate, perhaps with ALChemy. It's something I can't take into account from the coding side. Did you also try it entirely without it?


I don't use ALchemy for UT99 - it's not even activated for this game.


Smirftsch wrote on May 10th, 2016 at 6:52am:
OR there is possibly some other mixup:

Quote:
Log: ALAudio.ALAudioSubsystem.ALDevices
Log: ALAudio: ALDEVICES found 0:SBXFiAudio0001
Log: ALAudio: ALDEVICES found 1:OpenALSoftonLautsprecherCreativeSBXFi
Log: ALAudio: ALDEVICES found 2:OpenALSoftonSPDIFOutCreativeSBXFi
Log: ALAudio: ALDEVICES found 3:OpenALSoftonDigitalaudioHDMICreativeSBXFi
Log: ALAudio: ALDEVICES found 4:GenericSoftwareonLautsprecherCreativeSBXFi
Log: ALAudio: ALDEVICES found 5:GenericSoftwareonSPDIFOutCreativeSBXFi


Because I am really surprised about this: OpenALSofton... - which shouldn't be there if you are using Creative Labs dll.


I have both dll files in my UT directory (both Creative OpenAL & OpenALSoft) - that should be the reason Wink

Could that cause problems?

M2396
  
Back to top
 
IP Logged
 
Smirftsch
Forum Administrator
*****
Offline



Posts: 8012
Location: at home
Joined: Apr 30th, 1998
Gender: Male
Re: ALAudio for UnrealTournament - development and links
Reply #131 - May 10th, 2016 at 8:20am
Print Post  
Morpheus2396 wrote on May 10th, 2016 at 8:15am:
I have both dll files in my UT directory (both Creative OpenAL & OpenALSoft) - that should be the reason Wink

Could that cause problems?

I have both in my directory as well for testing purposes, while I keep the one not in use renamed, so it won't conflict.
Usually I use OpenAL32.dll and OpenAL32_creative.dll and rename it to OpenAL32_.dll and OpenAL32.dll if I switch the two.
But in any case your list above doesn't look like it should be.

Edited:
btw, you can make the sounds more apparent maybe by reducing ViewportVolumeIntensity but scaling up overall sound volume? Music can be set up separately yet with MusicAmplify

« Last Edit: May 10th, 2016 at 3:18pm by Smirftsch »  

Sometimes you have to lose a fight to win the war.
Back to top
WWWICQ  
IP Logged
 
r2rX
New Member
*
Offline


Oldunreal member

Posts: 9
Joined: Jun 10th, 2016
Re: ALAudio for UnrealTournament - development and links
Reply #132 - Jun 10th, 2016 at 11:53am
Print Post  
Hey there,

Out of curiosity, is there any plan to bring the plugin over to Linux? Smiley
  
Back to top
 
IP Logged
 
UTNerd24
New Member
*
Offline


Oldunreal member

Posts: 7
Joined: Aug 17th, 2016
Re: ALAudio for UnrealTournament - development and links
Reply #133 - Aug 17th, 2016 at 3:13am
Print Post  
Hey guys, I just joined this forum out of curiosity.

Love the new Driver, but half the time, Taunt voices don't play. However, the text is still there.

Am I missing something?
  
Back to top
 
IP Logged
 
Smirftsch
Forum Administrator
*****
Offline



Posts: 8012
Location: at home
Joined: Apr 30th, 1998
Gender: Male
Re: ALAudio for UnrealTournament - development and links
Reply #134 - Aug 17th, 2016 at 11:55am
Print Post  
hey there and welcome Smiley

Could you check the logs for anything regarding "ALAudio" ? May reveal something. Normally it should play anything without trouble.
  

Sometimes you have to lose a fight to win the war.
Back to top
WWWICQ  
IP Logged
 
Page Index Toggle Pages: 1 ... 7 8 [9] 10 11 12
Send TopicPrint
Bookmarks: del.icio.us Digg Facebook Google Google+ Linked in reddit StumbleUpon Twitter Yahoo