logo
Main

Forums

Downloads

Unreal-Netiquette

Donate for Oldunreal:
Donate

borderline

Links to our wiki:
Wiki

Walkthrough

Links

Tutorials

Unreal Reference

Usermaps

borderline

Contact us:
Submit News
Page Index Toggle Pages: [1] 2  Send TopicPrint
Hot Topic (More than 10 Replies) Unreal runs very slow when turning on decals (Read 9999 times)
gregaras
New Member
*
Offline


MF ftw ;)

Posts: 48
Location: Rokiskis, Lithuania
Joined: Mar 16th, 2011
Gender: Male
Unreal runs very slow when turning on decals
May 17th, 2011 at 5:52pm
Print Post  
Hey, there.

I have a strange problem with game Unreal. When I try to play it with Decal, it starts to lag (10-60 fps very big balance :/ ). When I turn it off, everything gets normal (60 fps). Why?

Computer specs:

Laptop Asus K52F
3GB of RAM
Intel 1GB
Intel i3 2,27 GHz
0,5 TB of disk space

Don't you thing, that my computer should run Unreal very smoothly "as a silk"?
  
Back to top
IP Logged
 
GreatEmerald
Oldunreal MasterPoster
*
Offline


The Great Emerald

Posts: 5361
Location: Vilnius, Lithuania
Joined: May 21st, 2007
Gender: Male
Re: Unreal runs very slow when turning on decals
Reply #1 - May 17th, 2011 at 8:39pm
Print Post  
Laptops are generally not optimised for games. What graphics card does it have, anyway? I know that my old laptop had an integrated card that didn't even support Hardware Transform and Lighting, so if your one is also missing some extensions, then this might be the cause. Though Unreal is generally more CPU-intensive.
Also, which renderer are you using?
  
Back to top
WWW  
IP Logged
 
gregaras
New Member
*
Offline


MF ftw ;)

Posts: 48
Location: Rokiskis, Lithuania
Joined: Mar 16th, 2011
Gender: Male
Re: Unreal runs very slow when turning on decals
Reply #2 - May 17th, 2011 at 9:15pm
Print Post  
I don't exactly know about my GPU. I think it's integrated in computer's processor. I try to look to SpeedFan, Speecy I can't find how exactly it calls.

I use OpenGL renderer.
  
Back to top
IP Logged
 
GreatEmerald
Oldunreal MasterPoster
*
Offline


The Great Emerald

Posts: 5361
Location: Vilnius, Lithuania
Joined: May 21st, 2007
Gender: Male
Re: Unreal runs very slow when turning on decals
Reply #3 - May 17th, 2011 at 10:13pm
Print Post  
Go to Start -> Run, enter "dxdiag", go to the Display tab. If it says something about Intel, then it's an integrated Intel one which is of pretty low power. You might want to update your drivers, though - Intel has a special tool to detect your system information on their website.

Try switching to D3D8 or D3D9 and see if that helps any. Would be ideal if you could switch to software and test it that way, but I'm pretty sure decals don't work there to begin with.
  
Back to top
WWW  
IP Logged
 
KeeperUTX
God Member
*****
Offline


Magician of Fire

Posts: 605
Location: Slovenia
Joined: Mar 15th, 2011
Gender: Male
Re: Unreal runs very slow when turning on decals
Reply #4 - May 19th, 2011 at 12:25pm
Print Post  
I play U1 on a laptop (aka Lappy-Crappy) and the details are AS LOW AS POSSIBLE and on netgames it lags like /()/&#!
  

Azhir uval nutarus. Azhir mudas ethanul. Dalektharu il dask daku. Riftuuz e thara samanar utamus. Elas umanes azarathan rakas ibna.
Back to top
 
IP Logged
 
gregaras
New Member
*
Offline


MF ftw ;)

Posts: 48
Location: Rokiskis, Lithuania
Joined: Mar 16th, 2011
Gender: Male
Re: Unreal runs very slow when turning on decals
Reply #5 - May 20th, 2011 at 3:58pm
Print Post  
Quote:
You might want to update your drivers, though - Intel has a special tool to detect your system information on their website.


I got a really bad problem after the update: http://www.sevenforums.com/installation-setup/164341-intel-hd-graphics-update-in...

Cry
  
Back to top
IP Logged
 
GreatEmerald
Oldunreal MasterPoster
*
Offline


The Great Emerald

Posts: 5361
Location: Vilnius, Lithuania
Joined: May 21st, 2007
Gender: Male
Re: Unreal runs very slow when turning on decals
Reply #6 - May 20th, 2011 at 6:00pm
Print Post  
Huh, that's odd. It would normally indicate that you installed the wrong driver version, which makes no sense... But if you have access to safe mode, then you can just install the right drivers manually or, if you happen to have the CD with the drivers, from there. If you can't do either of those, you should still be able to uninstall the driver itself and use the default framebuffer device.

Also, Blue Screens of Death are important, they contain information about what file is causing the system to crash! You should always take the time and write down the technical things there.
  
Back to top
WWW  
IP Logged
 
gregaras
New Member
*
Offline


MF ftw ;)

Posts: 48
Location: Rokiskis, Lithuania
Joined: Mar 16th, 2011
Gender: Male
BSoD doesn't show anymore after booting in LKGC
Reply #7 - May 21st, 2011 at 4:15pm
Print Post  
Huh, I can't remember... I used "Last Known Good Configuration" and everything worked quite normal (just couldn't play games, huh...) and I've got one table like this: (In Lithuanian, huh...)
Quote:
Problemos parašas:
  Problemos įvykio pavadinimas: (the name of problem incident)      BlueScreen
  OS versija: (OS version)      6.1.7600.2.0.0.256.48
  Vietos lokalė: (locale place)      1063

Papildoma informacija apie problemą: (Other information about the problem)
  BCCode:      7f
  BCP1:      00000000
  BCP2:      00000000
  BCP3:      00000000
  BCP4:      00000000
  OS Version:      6_1_7600
  Service Pack:      0_0
  Product:      256_1

Failai, kurie padeda apibūdinti problemą: (files, which help describing the problem)
  C:\Windows\Minidump\052011-49249-01.dmp
  C:\Users\Inga\AppData\Local\Temp\WER-66518-0.sysdata.xml

Skaitykite mūsų privatumo patvirtinimą internete: (read our privacy agreement in the internet)
  http://go.microsoft.com/fwlink/?linkid=104288&clcid=0x0427

Jei privatumo patvirtinimas tinkle neprieinamas, skaitykite mūsų privatumo patvirtinimą neprisijungę: (if privacy agreement isn't reachable in network, read our privacy agreement offline)
  C:\Windows\system32\lt-LT\erofflps.txt


The user of Windows 7 Forums, told me to use Windows 7 Repair disk to repair the system. I'll do it today, If I'll have some time...
  
Back to top
IP Logged
 
Smirftsch
Forum Administrator
*****
Offline



Posts: 7935
Location: at home
Joined: Apr 30th, 1998
Gender: Male
Re: Unreal runs very slow when turning on decals
Reply #8 - May 21st, 2011 at 7:17pm
Print Post  
yes, the repair function works pretty well in Windows7. Always worth the try Smiley
  

Sometimes you have to lose a fight to win the war.
Back to top
WWWICQ  
IP Logged
 
GreatEmerald
Oldunreal MasterPoster
*
Offline


The Great Emerald

Posts: 5361
Location: Vilnius, Lithuania
Joined: May 21st, 2007
Gender: Male
Re: Unreal runs very slow when turning on decals
Reply #9 - May 21st, 2011 at 11:16pm
Print Post  
By the way, if you were using Linux, in a case like that you'd just get booted out of the X Window System and could repair the system manually from the command line Smiley
  
Back to top
WWW  
IP Logged
 
gregaras
New Member
*
Offline


MF ftw ;)

Posts: 48
Location: Rokiskis, Lithuania
Joined: Mar 16th, 2011
Gender: Male
Re: Unreal runs very slow when turning on decals
Reply #10 - May 22nd, 2011 at 6:55pm
Print Post  
Quote:
yes, the repair function works pretty well in Windows7. Always worth the try


I tried it today, but It was just wasting of the time...

Quote:
By the way, if you were using Linux, in a case like that you'd just get booted out of the X Window System and could repair the system manually from the command line


The main OS of my computer was Linux, but in the first day, I had the laptop, mum went to repairman, to install programs and drivers, and he changed OS to Windows 7. I don't have Linux anymore.

Well, I've got my problem fixed. But Decals still don't work properly...
  
Back to top
IP Logged
 
GreatEmerald
Oldunreal MasterPoster
*
Offline


The Great Emerald

Posts: 5361
Location: Vilnius, Lithuania
Joined: May 21st, 2007
Gender: Male
Re: Unreal runs very slow when turning on decals
Reply #11 - May 22nd, 2011 at 9:09pm
Print Post  
So, it lags in D3D8 and D3D9 as well?
  
Back to top
WWW  
IP Logged
 
gregaras
New Member
*
Offline


MF ftw ;)

Posts: 48
Location: Rokiskis, Lithuania
Joined: Mar 16th, 2011
Gender: Male
Re: Unreal runs very slow when turning on decals
Reply #12 - Jun 26th, 2011 at 8:42pm
Print Post  
Sorry for a long delay. 

D3D8 - possible to play, maxed settings, detail textures doesn't work, decals work, Realtime shadows work. (30 fps, without shadows - 60 fps)

D3D9 - more lag than in D3D8, maxed settings, detail textures work, decals work, realtime shadows work. (30 fps)
  
Back to top
IP Logged
 
Hellkeeper
Global Moderator
*****
Offline


Soulless Automaton

Posts: 2815
Location: France
Joined: May 21st, 2008
Gender: Male
Re: Unreal runs very slow when turning on decals
Reply #13 - Jun 26th, 2011 at 11:16pm
Print Post  
What map are you running ? Maybe that map also happens to put some strain on some particular things.
  

You must construct additional pylons.
Back to top
WWW  
IP Logged
 
[]KAOS[]Casey
Ex Member


nedm

Gender: Male
Re: Unreal runs very slow when turning on decals
Reply #14 - Jun 27th, 2011 at 12:39am
Print Post  
This is probably (yet another) problem with realtime shadows being set to high/extreme
  
Back to top
 
IP Logged
 
Page Index Toggle Pages: [1] 2 
Send TopicPrint
Bookmarks: del.icio.us Digg Facebook Google Google+ Linked in reddit StumbleUpon Twitter Yahoo