For direct access use https://forums.oldunreal.com
It's been quite a while since oldunreal had an overhaul, but we are moving to another server which require some updates and changes. The biggest change is the migration of our old reliable YaBB forum to phpBB. This system expects you to login with your username and old password known from YaBB.
If you experience any problems there is also the usual "password forgotten" function. Don't forget to clear your browser cache!
If you have any further concerns feel free to contact me: Smirftsch@oldunreal.com

ALAudio for UnrealTournament - development and links

This forum is for the new audio renderer for UEngine 1 based games, like Unreal, UnrealTournament, DeusEx and Rune. Missing a Game? Want to develop yourself? Let us know!
User avatar
Morpheus2396
OldUnreal Member
Posts: 20
Joined: Sun Mar 13, 2016 12:35 pm

Re: ALAudio for UnrealTournament - development and links

Post by Morpheus2396 »

OpenAL Soft works perfectly in UT 2004 with a simple renaming (and other UE2/2.5 games too), just launch the game with this batch:

SET __ALSOFT_SUSPEND_CONTEXT=ignore
.\System\ut2004.exe
Shall/Can I have to insert this line in the .exe's launch options?

The "SUSPEND_CONTEXT=ignore" code - is that related to the sounds disappearing bug in UT/UT2004??? The question behind this question is: does Creative's OpenAL implementation alse have such a command?


@Smirftsch:

HRTF seems to work now - it didn't work, because "Output Format" in my Windows sound config was/is set to "24Bit, 96000Hz" and HRTF supports only 44,1 and 48KHz output -> I set it to "24Bit, 44100Hz" and now the sound through headphones is indeed three-dimensional BUT now I can notice the drop in fidelity and deepness of the sounds. However it's yet unclear whether this deterioration of sound quality is truly related to output frequency OR maybe to HRTF...

I will do some tests right now - testing 44,1 KHz vs. 96 KHz in other Games and I will compare OALSoft + HRTF to Creative HW OpenAL + CMSS-3D HP.

And right at this point, I'd like to know: is it somehow possible to get OALSoft working with CMSS-3D? Because CMSS-3D delivers truly reliable 3D/Surround-Sound to ANY game supporting surround sound and/or multi-channel sources...

M2396
User avatar
Morpheus2396
OldUnreal Member
Posts: 20
Joined: Sun Mar 13, 2016 12:35 pm

Re: ALAudio for UnrealTournament - development and links

Post by Morpheus2396 »

The bug of sound disappeared with xfi titanium pcu-e with new branch driver (2.40.xxx) is a bug from creative driver

There are lots of topics speak about this bug and creative have never made anything to resolve this bug. Now, this cards is at end of life. Then no new drivers is expected.

list of topics with this bugs
http://www.oldunreal.com/cgi-bin/yabb2/YaBB.pl?num=1400445026/15#15
https://www.lotro.com/forums/showthread ... 7fde139267
http://forums.creative.com/showthread.php?t=726283
etc

creative is only shit.
1.) So, does this mean, the guys working at Creative are already aware of this "bug" and that it affects several games?

2.) According to han, this issue is not a "bug" at all, but a new "function" or requirement...

Interrestingly, neither Doom 3 nor UT3 are affected by this "bug" - I played Doom 3 with OpenAL with the new(est) Creative driver (2.40.0015 - this one contains the skipping "bug", too) and there are neither sounds disappearing, nor does the game crash. Same for UT3 - UT3 crashes often, but I don't believe it's related to OpenAL...

M2396
Last edited by Morpheus2396 on Sun Nov 27, 2016 12:04 am, edited 1 time in total.
User avatar
willow31
OldUnreal Member
Posts: 5
Joined: Fri Sep 25, 2015 7:12 pm

Re: ALAudio for UnrealTournament - development and links

Post by willow31 »


1.) So, does this mean, the guys working at Creative are already aware of this "bug" and that it affects several games?
Yes, creative are already aware of this bug since many months (see the links that I quote but it exists lots of other linnks related) but there won't be any correction of this bug because support is stopped for xfi titanium since some months. altrhoug, the bug has been reported to creative many months before the end of support.

example of thread where some people refers to creative support the problem
https://www.lotro.com/forums/showthread ... -included)

2.) According to han, this issue is not a "bug" at all, but a new "function" or requirement...
i don't think it's a new function because only xfi titanium has this problem. Old xfi have not this problem even with new drivers.
if it was a new function, all xfi would have this problem.

see here
http://forums.creative.com/showthread.php?t=726283

Interrestingly, neither Doom 3 nor UT3 are affected by this "bug" - I played Doom 3 with OpenAL with the new(est) Creative driver (2.40.0015 - this one contains the skipping "bug", too) and there are neither sounds disappearing, nor does the game crash. Same for UT3 - UT3 crashes often, but I don't believe it's related to OpenAL...

M2396
Lots of openAL game are this problem: oldunreal, diablo1HD mod, BGEE, mass effect, Dungeons & Dragons Online, lotr online etc With open al soft or old driver before 2.40 branch, the problem disappeared.


Last edited by willow31 on Sun Nov 27, 2016 12:35 pm, edited 1 time in total.
User avatar
Wilhelm
OldUnreal Member
Posts: 2
Joined: Wed Jan 04, 2017 5:20 pm

Re: ALAudio for UnrealTournament - development and links

Post by Wilhelm »

Hello and a happy new year!

I have a question regarding the default values of ALAudio.

The values shown at the end of the first post are not the latest for obvious reasons, like the presence of "UseOriginalUnreal". Others are different like: MusicAmplify is 0 instead of 1 now and UseSpeechVolume is True instead of False.

Therefore I let it generate its own defaults, but here starts the confusion. If I implement it into a fresh UT installation with no entries in the INI and go to the Advanced Options and press "Reset To Defaults", some settings change!

These mainly are:
bSoundAttenuate=True (previously False)
MusicPanSeparation=0 (previously 50)
OutputRate=48000Hz (previously 44100Hz)

So, which are the real latest defaults please? ::)

One more thing, maybe thats normal behavior, but after selecting the new audio renderer in Advanced Options, just about 14 of these 30 entries are saved in the UT INI. I have to change a value in the GUI to get all written into the INI.
User avatar
han
Global Moderator
Posts: 686
Joined: Wed Dec 10, 2014 12:38 am

Re: ALAudio for UnrealTournament - development and links

Post by han »

For the Reset to Defaults button to work as expected, one would need to put the desired entries into Default.ini.
HX on Mod DB. Revision on Steam. Löffels on Patreon.
User avatar
gopostal
OldUnreal Member
Posts: 1003
Joined: Thu Jul 31, 2008 9:29 pm

Re: ALAudio for UnrealTournament - development and links

Post by gopostal »

Slight chuckle for a 'Wilhelm' posting in an audio section.

Explanation if needed
I don't want to give the end away
but we're all going to die one day
User avatar
Wilhelm
OldUnreal Member
Posts: 2
Joined: Wed Jan 04, 2017 5:20 pm

Re: ALAudio for UnrealTournament - development and links

Post by Wilhelm »

@gopostal: I havn't heard that one before ;D very interesting indeed.
This however is the only forum where I am active where I have to use another name instead of the username I've registered. Security is a neverending story, but this is as useless as forcing to use more and more complex passwords; especially when it comes to such crucial things in life like a (Unreal-)forum... :P

@han: Good suggestion! For some reason there were entries in the Defaults.ini that didn't match the actual ones. I've replaced them with those from the included inichanges.txt.
User avatar
wupfen
OldUnreal Member
Posts: 11
Joined: Sat Jan 17, 2015 2:47 pm

Re: ALAudio for UnrealTournament - development and links

Post by wupfen »

I played around with the volume a litte, don't want my UT to loud so I can listen to podcasts in the background.

But somehow I think the weapon explosions stay always the same volume, it seems an can only control the volume of the ambient noise. Anyone noticing anything similar?
User avatar
Smirftsch
Administrator
Posts: 8960
Joined: Wed Apr 29, 1998 10:00 pm

Re: ALAudio for UnrealTournament - development and links

Post by Smirftsch »

I guess it's probably because explosions pretty much max out the possible scale of volume, they still have a high value while anything else is long at 0 already.
Sometimes you have to lose a fight to win the war.
User avatar
wupfen
OldUnreal Member
Posts: 11
Joined: Sat Jan 17, 2015 2:47 pm

Re: ALAudio for UnrealTournament - development and links

Post by wupfen »

With Galaxy Audio the volume settings work as expected. But with the audio mod its always loud.
User avatar
David_OSU
OldUnreal Member
Posts: 29
Joined: Tue Jun 12, 2007 5:53 pm

Re: ALAudio for UnrealTournament - development and links

Post by David_OSU »

Smirftsch, I hate to bug you with a question you've already answered, but I can't find a complete description of the OpenAL settings. Back in 2011 you wrote:
"the settings are explained in the ReleaseNotes in the help directory. "
I've downloaded several different versions of your OpenAL driver, and none of them contain any ReleaseNotes (or help directory). I also downloaded the latest source, and couldn't find it in there either.

Can you point me to the location of the updated OpenAL settings description?

Thanks.
User avatar
Smirftsch
Administrator
Posts: 8960
Joined: Wed Apr 29, 1998 10:00 pm

Re: ALAudio for UnrealTournament - development and links

Post by Smirftsch »

uh no worries, all fine :)
Most things if not all should be on the first page of this topic. However, I think I need to do an update yet anyway and I will see to add all needed information then into the package.
Sometimes you have to lose a fight to win the war.
User avatar
David_OSU
OldUnreal Member
Posts: 29
Joined: Tue Jun 12, 2007 5:53 pm

Re: ALAudio for UnrealTournament - development and links

Post by David_OSU »

Thanks for the quick response, the comments on the first page are very helpful. And thanks for creating this driver and maintaining it -- it's great to have UT in surround sound again! I like to go back and play Unreal and RTNP every few years (nostalgia), and I use the Oldskool mod to do this in UT. Your driver and OpenAL Soft do a fantastic job with my 7.1 setup. I do have a few questions, if you have time:

So, are SpeechVolume and UseSpeechVolume related to the same sound channel? (I was wondering if the narration in RTNP might be using this channel. The narration comes through really loud.)

Is MusicPanSeparation not applicable for surround speaker setups? It seems that the music is always just in the front speakers even with surround enabled.

Are MusicStereoMix and MusicAmplify both affecting the gain of music?

If EmulateOldReverb=True and UseReverb=True, is the driver using EFX to implement the old reverb, or is the old reverb added before it is passed off to OpenAL?
User avatar
Smirftsch
Administrator
Posts: 8960
Joined: Wed Apr 29, 1998 10:00 pm

Re: ALAudio for UnrealTournament - development and links

Post by Smirftsch »

Glad to be of service, the entire purpose of it and this entire page is to keep this game alive and give people the chance to enjoy it, like you obviously do ;)

UseSpeechVolume just determines if this separate volume setting is even used or if it just relies on general volume setting.

Unreal and UT do not specifically make use of this, although there is indeed a separation for this in UScript it never was really made use of it, perhaps one can question if grunting and snuffling is really "speech". DeusEx however makes intense use of it. VoiceEvent in RTNP is set to SLOT_Talk, which is used to determine this, so yes, should.

Yes, there is no surround support specifically for music right now. Never came around to really check on this to be honest. Might be that the tracker music itself must support it, or also that tracker music doesn't support it in general, so that it might be faked in some way. I don't know (yet).

Stereo mixing does percentual left/right channel separation, this doesn't affect volume directly...or shouldn't affect at least :)

The driver uses a rough translation table to translate the old effects into new EFX presets, since there is no way to emulate the old reverb effects directly.

Sometimes you have to lose a fight to win the war.
User avatar
David_OSU
OldUnreal Member
Posts: 29
Joined: Tue Jun 12, 2007 5:53 pm

Re: ALAudio for UnrealTournament - development and links

Post by David_OSU »

Stereo mixing does percentual left/right channel separation
So both MusicPanSeparation and MusicStereoMix affect the left/right separation, but in different ways?

As for surround setups, I can see panning the music between left-center-right in the front, but I don't think it's a good idea to pipe any music to the side/rear channels. Seems like it would interfere with binaural location of 3D sounds. In fact, it might be best to keep the music on the left/rights only.
The driver uses a rough translation table to translate the old effects into new EFX presets, since there is no way to emulate the old reverb effects directly.
This is what I suspected, and it makes sense. I always thought the default Galaxy reverb was a bit overdone, and that the EAX reverb patch provided by Creative for some of the UT maps did a better job. The EFX reverb is closer to the EAX implementation, and sounds better IMHO.
User avatar
Smirftsch
Administrator
Posts: 8960
Joined: Wed Apr 29, 1998 10:00 pm

Re: ALAudio for UnrealTournament - development and links

Post by Smirftsch »

perhaps you want to check on http://xmp.sourceforge.net/libxmp.html
for more technical details :)
Sometimes you have to lose a fight to win the war.
User avatar
David_OSU
OldUnreal Member
Posts: 29
Joined: Tue Jun 12, 2007 5:53 pm

Re: ALAudio for UnrealTournament - development and links

Post by David_OSU »

perhaps you want to check on http://xmp.sourceforge.net/libxmp.html
for more technical details :)
Interesting. In the XMP documentation the defaults are given as:
  • stereo mix = 70
    default pan = 100
These are a little different than the defaults you provided in the first post:
  • stereo mix = 100
    default pan = 50
I found that default pan at 100 sounds better, still need to play around with stereo mix.

FYI, the SpeechVolume does not affect the narrator speech in RTNP, unfortunately. Still need to try it with ONP. It does affect creature noises, which could use a slight boost to keep them from being masked by the weapon sounds.
User avatar
Smirftsch
Administrator
Posts: 8960
Joined: Wed Apr 29, 1998 10:00 pm

Re: ALAudio for UnrealTournament - development and links

Post by Smirftsch »

the panning was the result of some complains about it when people compared it with galaxy, but therefor it is a setting, so anyone can adjust it themselves ;)
Sometimes you have to lose a fight to win the war.
User avatar
Cøi
OldUnreal Member
Posts: 2
Joined: Sat Feb 25, 2017 10:23 am

Re: ALAudio for UnrealTournament - development and links

Post by Cøi »

Are there any instructions for the installation of UT99 ALAudio or is putting these files in your System folder (and setting AudioDevice=ALAudio.ALAudioSubsystem) sufficient?


I have a specific problem with SpecialEvents playing sounds simultaneously at unequal volumes. It seems that concurrent audio events will somehow randomly gain priority over each other causing one sound effect to be very loud but the others very silent.

The only AudioDevice that doesn't have this problem is GalaxyAudioSubsystem: all effects play nicely in sync and do not override each other or something like that. However, I cannot increase the channels beyond 32 there (which I need for my special application). Could anyone point me to a solution? Thanks
Last edited by mush on Mon Jul 15, 2019 9:12 pm, edited 1 time in total.
sn260591
OldUnreal Member
Posts: 116
Joined: Wed Aug 17, 2011 2:54 am

Re: ALAudio for UnrealTournament - development and links

Post by sn260591 »

Are there any instructions for the installation of UT99 ALAudio or is putting these files in your System folder (and setting AudioDevice=ALAudio.ALAudioSubsystem) sufficient?


I have a specific problem with SpecialEvents playing sounds simultaneously at unequal volumes. It seems that concurrent audio events will somehow randomly gain priority over each other causing one sound effect to be very loud but the others very silent.

The only AudioDevice that doesn't have this problem is GalaxyAudioSubsystem: all effects play nicely in sync and do not override each other or something like that. However, I cannot increase the channels beyond 32 there (which I need for my special application). Could anyone point me to a solution? Thanks
First of all, set bSoundAttenuate to False.
If this does not help, try with the old version of OpenAL https://www.oldunreal.com/betatest/OpenAL_v2.2_UT.7z
Last edited by sn260591 on Tue Jul 16, 2019 12:32 pm, edited 1 time in total.
fakeaccount

Re: ALAudio for UnrealTournament - development and links

Post by fakeaccount »

I placed EFX in a map, but nothing changes in game. I'm using Alaudio device, but in game there is no echo.
User avatar
Smirftsch
Administrator
Posts: 8960
Joined: Wed Apr 29, 1998 10:00 pm

Re: ALAudio for UnrealTournament - development and links

Post by Smirftsch »

Most likely you missed some option somewhere. What did you do specifically?
Sometimes you have to lose a fight to win the war.
fakeaccount

Re: ALAudio for UnrealTournament - development and links

Post by fakeaccount »

My maps were made with EFXzone. They no longer run with the new openal.

Now when I make a map, even a cube room, with EFXzoneinfo, no reverb at all in game.

U227 EFX works fine. EFXzone years ago worked fine in UT. Now, with EFXzoneinfo it doesn't produce anything in game at all.
User avatar
Sergey
OldUnreal Member
Posts: 71
Joined: Wed Nov 25, 2015 5:16 am

Re: ALAudio for UnrealTournament - development and links

Post by Sergey »

There is a problem with this driver - the sound disappears in the menu. can this be fixed for game version 436 ?
User avatar
Neon_Knight
OldUnreal Member
Posts: 311
Joined: Tue Aug 25, 2009 9:02 pm

Re: ALAudio for UnrealTournament - development and links

Post by Neon_Knight »

Sergey wrote: Fri Feb 25, 2022 5:43 pm There is a problem with this driver - the sound disappears in the menu. can this be fixed for game version 436 ?
Better download v469. It contains all the fixes.
Localization project coordinator/spanish maintainer

Only the people that do nothing but criticize don't make mistakes. Do things. Make mistakes. Learn from them. And screw those who do nothing but throw poison and criticize.
Post Reply
  • Similar Topics
    Replies
    Views
    Last post

Return to “ALAudio (OpenAL), FMOD (FMOD3 and FMOD Ex) or other new audio renderer for UEngine 1 Games”