logo
Main

Forums

Downloads

Unreal-Netiquette

Donate for Oldunreal:
Donate

borderline

Links to our wiki:
Wiki

Walkthrough

Links

Tutorials

Unreal Reference

Usermaps

borderline

Contact us:
Submit News
Page Index Toggle Pages: 1 ... 9 10 [11] 12  Send TopicPrint
Very Hot Topic (More than 25 Replies) ALAudio for UnrealTournament - development and links (Read 34121 times)
Morpheus2396
New Member
*
Offline


Oldunreal member

Posts: 20
Joined: Mar 13th, 2016
Re: ALAudio for UnrealTournament - development and links
Reply #150 - Nov 26th, 2016 at 11:53pm
Print Post  
lowenz wrote on Aug 31st, 2016 at 2:47pm:
OpenAL Soft works perfectly in UT 2004 with a simple renaming (and other UE2/2.5 games too), just launch the game with this batch:

SET __ALSOFT_SUSPEND_CONTEXT=ignore
.\System\ut2004.exe



Shall/Can I have to insert this line in the .exe's launch options?

The "SUSPEND_CONTEXT=ignore" code - is that related to the sounds disappearing bug in UT/UT2004??? The question behind this question is: does Creative's OpenAL implementation alse have such a command?


@Smirftsch:

HRTF seems to work now - it didn't work, because "Output Format" in my Windows sound config was/is set to "24Bit, 96000Hz" and HRTF supports only 44,1 and 48KHz output -> I set it to "24Bit, 44100Hz" and now the sound through headphones is indeed three-dimensional BUT now I can notice the drop in fidelity and deepness of the sounds. However it's yet unclear whether this deterioration of sound quality is truly related to output frequency OR maybe to HRTF...

I will do some tests right now - testing 44,1 KHz vs. 96 KHz in other Games and I will compare OALSoft + HRTF to Creative HW OpenAL + CMSS-3D HP.

And right at this point, I'd like to know: is it somehow possible to get OALSoft working with CMSS-3D? Because CMSS-3D delivers truly reliable 3D/Surround-Sound to ANY game supporting surround sound and/or multi-channel sources...   

M2396
  
Back to top
 
IP Logged
 
Morpheus2396
New Member
*
Offline


Oldunreal member

Posts: 20
Joined: Mar 13th, 2016
Re: ALAudio for UnrealTournament - development and links
Reply #151 - Nov 27th, 2016 at 12:03am
Print Post  
willow31 wrote on Nov 26th, 2016 at 10:51pm:
The bug of sound disappeared with xfi titanium pcu-e with new branch driver (2.40.xxx) is a bug from creative driver

There are lots of topics speak about this bug and creative have never made anything to resolve this bug. Now, this cards is at end of life. Then no new drivers is expected.

list of topics with this bugs
http://www.oldunreal.com/cgi-bin/yabb2/YaBB.pl?num=1400445026/15#15
https://www.lotro.com/forums/showthread.php?563491-X-fi-Sound-Bug-quot-Disappear...
http://forums.creative.com/showthread.php?t=726283
etc

creative is only shit.


1.) So, does this mean, the guys working at Creative are already aware of this "bug" and that it affects several games?

2.) According to han, this issue is not a "bug" at all, but a new "function" or requirement...

Interrestingly, neither Doom 3 nor UT3 are affected by this "bug" - I played Doom 3 with OpenAL with the new(est) Creative driver (2.40.0015 - this one contains the skipping "bug", too) and there are neither sounds disappearing, nor does the game crash. Same for UT3 - UT3 crashes often, but I don't believe it's related to OpenAL...

M2396
  
Back to top
 
IP Logged
 
willow31
New Member
*
Offline


Oldunreal member

Posts: 5
Joined: Sep 25th, 2015
Re: ALAudio for UnrealTournament - development and links
Reply #152 - Nov 27th, 2016 at 12:24pm
Print Post  
Morpheus2396 wrote on Nov 27th, 2016 at 12:03am:
1.) So, does this mean, the guys working at Creative are already aware of this "bug" and that it affects several games?

Yes, creative are already aware of this bug since many months (see the links that I quote but it exists lots of other linnks related) but there won't be any correction of this bug because support is stopped for xfi titanium since some months. altrhoug, the bug has been reported to creative many months before the end of support.

example of thread where some people refers to creative support the problem
https://www.lotro.com/forums/showthread.php?563491-X-fi-Sound-Bug-quot-Disappear...)


Morpheus2396 wrote on Nov 27th, 2016 at 12:03am:
2.) According to han, this issue is not a "bug" at all, but a new "function" or requirement...

i don't think it's a new function because only xfi titanium has this problem. Old xfi have not this problem even with new drivers.
if it was a new function, all xfi would have this problem.

see here
http://forums.creative.com/showthread.php?t=726283


Morpheus2396 wrote on Nov 27th, 2016 at 12:03am:
Interrestingly, neither Doom 3 nor UT3 are affected by this "bug" - I played Doom 3 with OpenAL with the new(est) Creative driver (2.40.0015 - this one contains the skipping "bug", too) and there are neither sounds disappearing, nor does the game crash. Same for UT3 - UT3 crashes often, but I don't believe it's related to OpenAL...

M2396

Lots of openAL game are this problem: oldunreal, diablo1HD mod, BGEE, mass effect, Dungeons & Dragons Online, lotr online etc With open al soft or old driver before 2.40 branch, the problem disappeared.


  
Back to top
 
IP Logged
 
Wilhelm
New Member
*
Offline


Oldunreal member

Posts: 2
Joined: Jan 4th, 2017
Re: ALAudio for UnrealTournament - development and links
Reply #153 - Jan 4th, 2017 at 7:38pm
Print Post  
Hello and a happy new year!

I have a question regarding the default values of ALAudio.

The values shown at the end of the first post are not the latest for obvious reasons, like the presence of "UseOriginalUnreal". Others are different like: MusicAmplify is 0 instead of 1 now and UseSpeechVolume is True instead of False.

Therefore I let it generate its own defaults, but here starts the confusion. If I implement it into a fresh UT installation with no entries in the INI and go to the Advanced Options and press "Reset To Defaults", some settings change!

These mainly are:
bSoundAttenuate=True (previously False)
MusicPanSeparation=0 (previously 50)
OutputRate=48000Hz (previously 44100Hz)

So, which are the real latest defaults please? Roll Eyes

One more thing, maybe thats normal behavior, but after selecting the new audio renderer in Advanced Options, just about 14 of these 30 entries are saved in the UT INI. I have to change a value in the GUI to get all written into the INI.
  
Back to top
 
IP Logged
 
han
Global Moderator
Unreal Rendering Guru
Developer Team
*****
Offline


Oldunreal member

Posts: 517
Location: Germany
Joined: Dec 10th, 2014
Gender: Male
Re: ALAudio for UnrealTournament - development and links
Reply #154 - Jan 5th, 2017 at 5:29am
Print Post  
For the Reset to Defaults button to work as expected, one would need to put the desired entries into Default.ini.
  

HX on Mod DB. Revision on Steam.
Back to top
 
IP Logged
 
gopostal
Betatester
Offline


Retired

Posts: 711
Joined: Jul 31st, 2008
Gender: Male
Re: ALAudio for UnrealTournament - development and links
Reply #155 - Jan 5th, 2017 at 6:13am
Print Post  
Slight chuckle for a 'Wilhelm' posting in an audio section.

Explanation if needed
  

I'm outta here. C ya!
Back to top
 
IP Logged
 
Wilhelm
New Member
*
Offline


Oldunreal member

Posts: 2
Joined: Jan 4th, 2017
Re: ALAudio for UnrealTournament - development and links
Reply #156 - Jan 6th, 2017 at 12:37am
Print Post  
@gopostal: I havn't heard that one before Grin very interesting indeed.
This however is the only forum where I am active where I have to use another name instead of the username I've registered. Security is a neverending story, but this is as useless as forcing to use more and more complex passwords; especially when it comes to such crucial things in life like a (Unreal-)forum... Tongue

@han: Good suggestion! For some reason there were entries in the Defaults.ini that didn't match the actual ones. I've replaced them with those from the included inichanges.txt.
  
Back to top
 
IP Logged
 
wupfen
New Member
*
Offline


Oldunreal member

Posts: 11
Joined: Jan 17th, 2015
Re: ALAudio for UnrealTournament - development and links
Reply #157 - Feb 26th, 2017 at 3:29pm
Print Post  
I played around with the volume a litte, don't want my UT to loud so I can listen to podcasts in the background.

But somehow I think the weapon explosions stay always the same volume, it seems an can only control the volume of the ambient noise. Anyone noticing anything similar?
  
Back to top
 
IP Logged
 
Smirftsch
Forum Administrator
*****
Offline



Posts: 7500
Location: at home
Joined: Apr 30th, 1998
Gender: Male
Re: ALAudio for UnrealTournament - development and links
Reply #158 - Feb 28th, 2017 at 11:29am
Print Post  
I guess it's probably because explosions pretty much max out the possible scale of volume, they still have a high value while anything else is long at 0 already.
  

Sometimes you have to lose a fight to win the war.
Back to top
WWWICQ  
IP Logged
 
wupfen
New Member
*
Offline


Oldunreal member

Posts: 11
Joined: Jan 17th, 2015
Re: ALAudio for UnrealTournament - development and links
Reply #159 - Mar 27th, 2017 at 7:33pm
Print Post  
With Galaxy Audio the volume settings work as expected. But with the audio mod its always loud.
  
Back to top
 
IP Logged
 
David_OSU
New Member
*
Offline


Oldunreal member

Posts: 29
Location: Columbus, OH
Joined: Jun 12th, 2007
Gender: Male
Re: ALAudio for UnrealTournament - development and links
Reply #160 - Aug 7th, 2017 at 2:48pm
Print Post  
Smirftsch, I hate to bug you with a question you've already answered, but I can't find a complete description of the OpenAL settings.  Back in 2011 you wrote:

Quote:
"the settings are explained in the ReleaseNotes in the help directory. "


I've downloaded several different versions of your OpenAL driver, and none of them contain any ReleaseNotes (or help directory).  I also downloaded the latest source, and couldn't find it in there either.

Can you point me to the location of the updated OpenAL settings description? 

Thanks.
  
Back to top
 
IP Logged
 
Smirftsch
Forum Administrator
*****
Offline



Posts: 7500
Location: at home
Joined: Apr 30th, 1998
Gender: Male
Re: ALAudio for UnrealTournament - development and links
Reply #161 - Aug 8th, 2017 at 8:25am
Print Post  
uh no worries, all fine Smiley
Most things if not all should be on the first page of this topic. However, I think I need to do an update yet anyway and I will see to add all needed information then into the package.
  

Sometimes you have to lose a fight to win the war.
Back to top
WWWICQ  
IP Logged
 
David_OSU
New Member
*
Offline


Oldunreal member

Posts: 29
Location: Columbus, OH
Joined: Jun 12th, 2007
Gender: Male
Re: ALAudio for UnrealTournament - development and links
Reply #162 - Aug 8th, 2017 at 2:51pm
Print Post  
Thanks for the quick response, the comments on the first page are very helpful.  And thanks for creating this driver and maintaining it -- it's great to have UT in surround sound again!  I like to go back and play Unreal and RTNP every few years (nostalgia), and I use the Oldskool mod to do this in UT.  Your driver and OpenAL Soft do a fantastic job with my 7.1 setup.  I do have a few questions, if you have time:

So, are SpeechVolume and UseSpeechVolume related to the same sound channel?  (I was wondering if the narration in RTNP might be using this channel.  The narration comes through really loud.)

Is MusicPanSeparation not applicable for surround speaker setups?  It seems that the music is always just in the front speakers even with surround enabled.

Are MusicStereoMix and MusicAmplify both affecting the gain of music?

If EmulateOldReverb=True and UseReverb=True, is the driver using EFX to implement the old reverb, or is the old reverb added before it is passed off to OpenAL?
  
Back to top
 
IP Logged
 
Smirftsch
Forum Administrator
*****
Offline



Posts: 7500
Location: at home
Joined: Apr 30th, 1998
Gender: Male
Re: ALAudio for UnrealTournament - development and links
Reply #163 - Aug 8th, 2017 at 4:35pm
Print Post  
Glad to be of service, the entire purpose of it and this entire page is to keep this game alive and give people the chance to enjoy it, like you obviously do Wink

UseSpeechVolume just determines if this separate volume setting is even used or if it just relies on general volume setting.

Unreal and UT do not specifically make use of this, although there is indeed a separation for this in UScript it never was really made use of it, perhaps one can question if grunting and snuffling is really "speech". DeusEx however makes intense use of it. VoiceEvent in RTNP is set to SLOT_Talk, which is used to determine this, so yes, should.

Yes, there is no surround support specifically for music right now. Never came around to really check on this to be honest. Might be that the tracker music itself must support it, or also that tracker music doesn't support it in general, so that it might be faked in some way. I don't know (yet).

Stereo mixing does percentual left/right channel separation, this doesn't affect volume directly...or shouldn't affect at least Smiley

The driver uses a rough translation table to translate the old effects into new EFX presets, since there is no way to emulate the old reverb effects directly.

  

Sometimes you have to lose a fight to win the war.
Back to top
WWWICQ  
IP Logged
 
David_OSU
New Member
*
Offline


Oldunreal member

Posts: 29
Location: Columbus, OH
Joined: Jun 12th, 2007
Gender: Male
Re: ALAudio for UnrealTournament - development and links
Reply #164 - Aug 8th, 2017 at 10:10pm
Print Post  
Smirftsch wrote on Aug 8th, 2017 at 4:35pm:
Stereo mixing does percentual left/right channel separation

So both MusicPanSeparation and MusicStereoMix affect the left/right separation, but in different ways?

As for surround setups, I can see panning the music between left-center-right in the front, but I don't think it's a good idea to pipe any music to the side/rear channels.  Seems like it would interfere with binaural location of 3D sounds.  In fact, it might be best to keep the music on the left/rights only.

Smirftsch wrote on Aug 8th, 2017 at 4:35pm:
The driver uses a rough translation table to translate the old effects into new EFX presets, since there is no way to emulate the old reverb effects directly.

This is what I suspected, and it makes sense.  I always thought the default Galaxy reverb was a bit overdone, and that the EAX reverb patch provided by Creative for some of the UT maps did a better job.  The EFX reverb is closer to the EAX implementation, and sounds better IMHO.
  
Back to top
 
IP Logged
 
Page Index Toggle Pages: 1 ... 9 10 [11] 12 
Send TopicPrint
Bookmarks: del.icio.us Digg Facebook Google Google+ Linked in reddit StumbleUpon Twitter Yahoo