logo
Main

Forums

Downloads

Unreal-Netiquette

Donate for Oldunreal:
Donate

borderline

Links to our wiki:
Wiki

Walkthrough

Links

Tutorials

Unreal Reference

Usermaps

borderline

Contact us:
Submit News
Page Index Toggle Pages: 1 Send TopicPrint
Normal Topic ini entry to force vsync in opengl (Read 10417 times)
Etern@l
New Member
*
Offline


I love YaBB 1G - SP1!

Posts: 2
Joined: Sep 10th, 2003
ini entry to force vsync in opengl
Sep 10th, 2003 at 9:50pm
Print Post  
Hi,

First Great job for the ogl driver, it rocks !!

I have juste a wish  Wink

I'd like forcing vsync in ogl from a variable in the ini. Is it possible ?

I know it can be done in the driver but, shame on me, I play also Quake 3 a lot and I need vsync off in q3. I'd like not to swap the setting in my driver each time I change game.

I have set the driver (radeon 3.7) to default vsync on (application preference) with rage 3D tweaker, but it does not work with the unreal opengl patch (guess that vsync off is hard coded somewhere).

The only way to force vsync on in unreal is to set the driver on always vsync but in this case the Q3 variable can't bypass the setting and I have vsync on in Q3...

Thanks again !

Etern@l

  
Back to top
 
IP Logged
 
hund_schraube
New Member
*
Offline


point away from face and
fire

Posts: 22
Joined: Aug 4th, 2002
Re: ini entry to force vsync in opengl
Reply #1 - Sep 21st, 2003 at 11:26pm
Print Post  
UseVSync=true
  
Back to top
 
IP Logged
 
mario64
New Member
*
Offline


I love YaBB 1G - SP1!

Posts: 2
Joined: Sep 22nd, 2003
Re: ini entry to force vsync in opengl
Reply #2 - Sep 22nd, 2003 at 10:11pm
Print Post  
Thank you SO much! I can't tell you how long I've been looking for a way to enable vsynch using this renderer without having to change vsynch to "always on" in my video card drivers. Woo Hoo!!!   Grin

Mario64
  
Back to top
 
IP Logged
 
Etern@l
New Member
*
Offline


I love YaBB 1G - SP1!

Posts: 2
Joined: Sep 10th, 2003
Re: ini entry to force vsync in opengl
Reply #3 - Sep 26th, 2003 at 5:07pm
Print Post  
Hello,

Sorry to say that UseVSync=true works only with the D3D driver, I'd like enabling vsync in openGL driver.

Thanks for the try anyway !

Etern@l
  
Back to top
 
IP Logged
 
mario64
New Member
*
Offline


I love YaBB 1G - SP1!

Posts: 2
Joined: Sep 22nd, 2003
Re: ini entry to force vsync in opengl
Reply #4 - Sep 26th, 2003 at 6:13pm
Print Post  
Quote:
Hello,

Sorry to say that UseVSync=true works only with the D3D driver, I'd like enabling vsync in openGL driver.

Thanks for the try anyway !

Etern@l

It works just fine for me using this site's openGL renderer. Maybe it's an issue with the 3.7 CATs. Have you tried any other drivers? I'm using the 3.5 hotfixes.

Mario64
  
Back to top
 
IP Logged
 
node357
New Member
*
Offline


Oldunreal member

Posts: 1
Joined: Jul 10th, 2010
Re: ini entry to force vsync in opengl
Reply #5 - Jul 10th, 2010 at 3:50am
Print Post  
I have tried everything I can to enable VSync in OpenGL mode. UseVSync=True in the ini file, Changing swapinterval values between -1 and 3, and finally attempting to force in NVIDIA control panel. Nothing works. I simply can't get vsync here.
  
Back to top
 
IP Logged
 
Smirftsch
Forum Administrator
*****
Offline



Posts: 7471
Location: at home
Joined: Apr 30th, 1998
Gender: Male
Re: ini entry to force vsync in opengl
Reply #6 - Jul 20th, 2010 at 11:39am
Print Post  
SwapInterval - [Integer]
Controls V Sync. If set to the default value of -1, the default buffer swapping method is used. Set to 0 to disable V Sync. Set to 1 to enable V Sync. Set to higher values for one frame every N screen refreshes. Not all video drivers support values higher than 1.

Other than that there is nothing more. Maybe buggy driver? Seems to work fine so far on any machine I tried.
  

Sometimes you have to lose a fight to win the war.
Back to top
WWWICQ  
IP Logged
 
LeXa2 (A. Loukianov)
Junior Member
**
Offline


*nix specialist

Posts: 72
Location: Moscow, Russian Federation
Joined: Feb 8th, 2011
Gender: Male
Re: ini entry to force vsync in opengl
Reply #7 - Feb 8th, 2011 at 7:43pm
Print Post  
Posting here to report that with 227e under linux there are problems controlling AA quality and vsync using UnrealLinux.ini file. It simply don't work no matter the values I specify in SwapInterval, UseAA, NumAASamples and AAFilterHint. Forcing AA and VSync using nVIDIA X Server Settings (driver control panel) works. Unfortunately enabling vsync seems to introduce slight mouse input lag. It is very slight but I can 'sense' it after many years spent playing 3d shooters.

Trying to use 227f OpenGLDrv with 227e leads to game starting up correctly but showing no graphical output at all (i.e. blank black screen). As 227g is (hopefully) very near this report is just an "informational" one and I will re-test the problem as soon as 227g would be available to download.
  
Back to top
GTalkSkype/VoIPICQ  
IP Logged
 
LeXa2 (A. Loukianov)
Junior Member
**
Offline


*nix specialist

Posts: 72
Location: Moscow, Russian Federation
Joined: Feb 8th, 2011
Gender: Male
Re: ini entry to force vsync in opengl
Reply #8 - Feb 8th, 2011 at 7:59pm
Print Post  
Upd. Finally got 227f to start up without sigsegv on my system and checked if the problem with enabling vsync/AA using UnrealLinux.ini affects this version too. Unfortunately it does. The only way to get 227f use vsync and antialiasing on my linux box was to force both of them with nVIDIA driver control panel.
  
Back to top
GTalkSkype/VoIPICQ  
IP Logged
 
Page Index Toggle Pages: 1
Send TopicPrint
Bookmarks: del.icio.us Digg Facebook Google Google+ Linked in reddit StumbleUpon Twitter Yahoo